[SOLVED] Re: 1GB USB-Fat device refusing access

Tino Engel elrap at web.de
Mon Nov 26 13:43:07 PST 2007

Tino Engel schrieb:
> Dear all,
> I am currently trying to get my mp3-player to work with freebsd.
> FreeBSD freebsdangel.de 7.0-BETA3 FreeBSD 7.0-BETA3 #1: Sun Nov 18 
> 15:40:16 CET 2007     
> root at freebsdangel.de:/usr/obj/usr/src/sys/GENERIC  i386
> When attaching the device to an usb-port I receive an error message as 
> follows:
> uhub2: device problem (INVAL), disabling port 6
> I slightly recall, that for FAT devices over 512MB some 
> "largefile-option" had to be enabled.
> But as far as I have googled, the option is deprecated on 7.0.
> It makes no difference running the device in MTP (Microsoft 
> semi-proprietary MediaTransferProtokoll as implemented in libmtp on 
> FreeBSD) or MSC (MassStorageClass -> "external usb-disc mode") mode, 
> the error stay the same.
> Common Linux-Test reports say my device is working fine on linux. So 
> it should on FreeBSD I guess.
> Has anyone an idea, how to get more detailled input (than I got from 
> dmesg) or how to enable the device.
> Best regards, Tino
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"
Well, I solved the problem myself.
Attaching to another uhub solved the problem (whysoever)

Greez, Tino

More information about the freebsd-questions mailing list