What kind of audio device is this?

P.U.Kruppa ulrich at pukruppa.net
Fri Nov 9 10:59:46 PST 2007

On Fri, 9 Nov 2007, Adam J Richardson wrote:

> P.U.Kruppa wrote:
>>>> dmesg says I have got
>>>>    ugen0: <vendor 0x0d8c PnP Audio Device, class 0/0, rev 1.10/0.10,
>>>>    addr 4> on uhub0
>>>> on board.
>>>> What is this? Do we have a driver for it?
> <snip>
>>>> Of course I tried
>>>>      # kldload snd_driver
>>>> but all I get is
>>>>      # cat /dev/sndstat
>>>>      FreeBSD Audio Driver (newpcm: 64bit 2007061600/amd64)
>>>>      Installed devices:
>>>> I am running
>>>>    FreeBSD 7.0-BETA2 FreeBSD 7.0-BETA2 #0:
>>>>    Sat Nov  3 17:55:42 CET 2007 amd64
> Hi Peter,
> I also have a USB sound device which wouldn't detect until I loaded 
> snd_uaudio. Now I can play my CDs through my 5.1 system, but I had to install 
> both OSS and eSound to do it. I think the idea is everything goes to eSound, 
> which is piped through the OSS mixer.
> My sound device now identifies [on FreeBSD 6.3-PRERELEASE] as:
> uaudio0: vendor 0x0c45 USB Audio, rev 1.10/1.00, addr 2
> uaudio0: audio rev 1.00
> pcm0: <USB Audio> on uaudio0
Yes, great thanks Adam!

For the records:
As you said I have installed audio/oss and audio/esound.
I couldn't start snd_uaudio at runtime, so I put
into /boot/loader.conf and rebooted.
After that everything worked fine.

On my FreeBSD 7.0 I can even see /dev/dsp and when I do a
      	# cat /dev/sndstat
I get
     	FreeBSD Audio Driver (newpcm: 64bit 2007061600/amd64)
  	Installed devices:
  	pcm0: <USB Audio> at ? kld snd_uaudio [GIANT] (1p:1v/1r:1v
  	channels duplex default)
          mode 1:(output) 8ch, 16/16bit, pcm, 44100,48000Hz
          mode 2:(output) 2ch, 16/16bit, pcm, 44100,48000Hz
          mode 3:(output) 4ch, 16/16bit, pcm, 44100,48000Hz
          mode 4:(output) 6ch, 16/16bit, pcm, 44100,48000Hz
          mode 5:(output) 2ch, 16/16bit, pcm, 48000Hz
          mode 1:(input) 2ch, 16/16bit, pcm, 44100,48000Hz

That's it!

Thanks again,

> which is every bit as dull as yours.
> By the way I don't have a /dev/dsp either. It doesn't seem to be required.
> HtH,
> Adam J Richardson
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

Peter Ulrich Kruppa

More information about the freebsd-questions mailing list