No matter what I try I can't get Nvidia 3d acceleration to work. Please help!

Pieter de Goeje pieter at
Tue Mar 13 19:43:09 UTC 2007

Op dinsdag 13 maart 2007 17:44, schreef hxc at
> Thank you for your extensive answer. I tried both your method and the
> method described in the handbook*. I still get the same error message
> though**. I have attached MYKERNEL, maybe you can take a look at it to
> see if somethings wrong?
> [snip]
> Error message
> login: NVRM: AGP cannot be enabled on this combination of the AMD CPU
> and OS kernel
> NVRM: kernel upgrade recommended.
Ok, the only other reason I can think of right now is that your motherboard's 
agp chipset isn't supported by the nvidia driver. In that case you'll need to 
load the FreeBSD agp driver and recompile the nvidia driver with support for 
freebsd's agp driver.

# cd /usr/ports/x11/nvidia-driver
# make config
# make clean
# make deinstall reinstall clean

Also, you need to go back to the "GENERIC" kernel w/ agp included, or load agp 
by specifying agp_load="yes" in /boot/loader.conf.

Hope this helps,

Pieter de Goeje

More information about the freebsd-questions mailing list