X11 forwarding problems in FreeBSD 6.2 - no xauth data? [SOLVED]

Pollywog lists-fbsd at shadypond.com
Thu Jul 12 14:44:45 UTC 2007

On Thursday 12 July 2007 13:59:54 Andy Greenwood wrote:

> I had this same problem recently on my server. the sshd_config man
> page says that the default location for xauth is /usr/X11R6/bin/xauth,
> but mine was installed as /usr/local/bin/xauth. adding
> XAuthLocation /usr/local/bin/xauth
> to my sshd_config and restarting sshd fixed it for me.

Interesting, because that was the first thing I did, but it did not solve the 
problem.  What did solve the problem was to add the same line to 
my /etc/ssh/ssh_config in the "Host *" section.

This only fixed one side of the connection, so I can connect from the FreeBSD 
host to the Linux hosts.  On the Linux hosts, I put 

XAuthLocation /usr/bin/xauth  in their /etc/ssh/ssh_config files but that did 
not fix the problem from the Linux hosts to FreeBSD.  I believe it is because 
of the way that OpenSSH was compiled on FreeBSD but I am not certain.


More information about the freebsd-questions mailing list