fetch hangs during Make, portupgrade -a, or portmanager -u..

Dinesh Pandian dineshpandian at gmail.com
Thu Jul 5 15:27:10 UTC 2007

No firewall/NAT along the path. It's a direct connection.
I'm pretty new to freebsd so I'm guessing that I did
something wrong with network config or something. :)

-- Dinesh

On 7/5/07, Lowell Gilbert <freebsd-questions-local at be-well.ilk.org> wrote:
> "Dinesh Pandian" <dineshpandian at gmail.com> writes:
> > Please help me out with a really annoying little problem that bugs me
> > everytime I try to install applications from ports.
> >
> > When I try to run portupgrade -a  or  portmanager -u,
> > when Make fetches the files from the servers, fetch
> > normally hangs randomly sometime through the downloading
> > of the distfile. The only solution I've thought about is aborting
> > the upgrade procedure and issuing the same command again,
> > hoping that fetch resumes where it left off.
> >
> > In bigger files, > 5MB, I'd have to repeat this process several
> > times to download a single distfile.
> >
> > I've tried setting the FTP_PASSIVE_MODE env ON and OFF
> > to no avail.
> >
> > I can't seem to find a problem with the internet connection
> > as httpd and ftpd works perfectly fine!
> Is there a firewall in the way?  NAT?
> Have you tried using fetch(1) from the command line, with increased
> verbosity level?

Dinesh Pandian,
SOLARA Networks.

More information about the freebsd-questions mailing list