Xorg on FreeBSD does not work

Neeraj Sharma neeraj.dl at gmail.com
Thu Feb 15 08:54:40 UTC 2007

I tried copying my xorg.conf from Ubuntu (which automatically probes
everything and creates a xorg.conf) and tried to use on FreeBSD. But still
it hangs... I wonder if its because some drivers are missing in FreeBSD for
my monitor. My laptop has ATI Radeon 9000IGP in case that rings a bell to
someone in the same situation as me b4.
Here is xorg.conf from my Ubuntu Install
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
    FontPath    "unix/:7100"            # local font server
    # if the local font server has problems, we can fall back on these
    FontPath    "/usr/lib/X11/fonts/misc"
    FontPath    "/usr/lib/X11/fonts/cyrillic"
    FontPath    "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/Type1"
    FontPath    "/usr/lib/X11/fonts/CID"
    FontPath    "/usr/lib/X11/fonts/100dpi"
    FontPath    "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

Section "Module"
    Load    "bitmap"
    Load    "dbe"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "record"
    Load    "type1"
    Load    "vbe"

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "keyboard"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc104"
    Option        "XkbLayout"    "us"

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
    Option        "ZAxisMapping"        "4 5"
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option        "HorizScrollDelta"    "0"

Section "Device"
    Identifier    "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200
    Driver        "ati"
    BusID        "PCI:1:5:0"

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    Modeline    "1280x800 at 60" 83.91 1280 1312 1624 1656 800 816 824 841

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1280x800"
    SubSection "Display"
        Depth        4
        Modes        "1280x800"
    SubSection "Display"
        Depth        8
        Modes        "1280x800"
    SubSection "Display"
        Depth        15
        Modes        "1280x800"
    SubSection "Display"
        Depth        16
        Modes        "1280x800"
    SubSection "Display"
        Depth        24
        Modes        "1280x800"

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"

Section "DRI"
    Mode    0666

Thanks for the help!


On 2/15/07, Christian Walther <cptsalek at gmail.com> wrote:
> On 15/02/07, Abdullah Ibn Hamad Al-Marri <almarrie at gmail.com> wrote:
> > On 2/15/07, Neeraj Sharma <neeraj.dl at gmail.com> wrote:
> > > I am a newbie to FreeBSD world. I am trying to install FreeBSD6.2 on
> my HP
> > > zv5240us laptop. Everything else went off fine except the X config. I
> ran
> > > the command X -configure which created a xorg.conf.new file. When I
> use that
> > > to run X it just shows a blank screen and I am not able to go back to
> the
> > > console also.
> > >
> > > I tried playing around with the parameters in xorg.conf.new file but
> without
> > > success. If anyone can help me with this it will be great...
> > >
> > > --
> > > Thanks & Regards,
> > > Neeraj Sharma
> >
> > That is alright to show you xorg works or not.
> Yes, a blank screen and a locked keyboard is a perfect description of
> an X configuration that isn't working. ;-)
> >
> > After doing that press ctrl+alt+backspace
> >
> > Then #cp /root/xorg.conf.new /etc/X11/xorg.conf then type startx or
> > reboot your notebook.
> Sorry for correcting, but this is not adviseable at this point. His X
> isn't working obviously, so installing xorg.conf into the right place
> would lead to more problems, without solving anything.
> He can do so when the X configuration is working.
> >
> > --
> > Regards,
> >
> > -Abdullah Ibn Hamad Al-Marri
> > Arab Portal
> > http://www.WeArab.Net/
> Regards
> Christian

Thanks & Regards,
Neeraj Sharma

More information about the freebsd-questions mailing list