Viewing on remote PC

Gerard gerard at
Wed Feb 14 22:02:12 UTC 2007

On Wednesday February 14, 2007 at 08:02:38 (AM) Vince wrote:

> White Hat wrote:


> Windows != Xwindows and you need xwindows to display xwindows programs.
> what you will need to do is either setup VNC server on your Freebsd
> machine and access it via VNC to get a desktop (realvnc, tridia and
> tight vnc are in ports,) or install X windows on your windows machine
> (and make sure X forwarding is enabled in ssh.) I'd probably VNC as its
> easier and faster except on high bandwidth links, but if you really want
> Xwindow on your windows machine or
> are a good place to start.
OK, I installed 'tightvnc' from ports. That went OK.

Then, I started the process by entering: 'vncserver' at the command
prompt on the FBSD machine. The first time this ran it asked for
information which I provided. Now when I invoke it, it runs silently.
This is the contents of the log file it creates.

// Contents of: ~/.vnc/ //

14/02/07 10:42:32 Xvnc version TightVNC-1.3.8
14/02/07 10:42:32 Copyright (C) 2000-2006 Constantin Kaplinsky
14/02/07 10:42:32 Copyright (C) 1999 AT&T Laboratories Cambridge
14/02/07 10:42:32 All Rights Reserved.
14/02/07 10:42:32 See for information on TightVNC
14/02/07 10:42:32 Desktop name 'X' (
14/02/07 10:42:32 Protocol versions supported: 3.7t, 3.7, 3.3
14/02/07 10:42:32 Listening for VNC connections on TCP port 5901
14/02/07 10:42:32 Listening for HTTP connections on TCP port 5801
14/02/07 10:42:32   URL

// End Log //

I have the following in the 'putty' configuration

Under SSL / X11, I have this:

X Display location: localhost:0
I have tried with both: Enable X forwarding checked and unchecked
without any difference.

Under SSH / Tunnels, I have this:


I am not sure about the port # 5905. I simply copied it from a example I found.
I have tried 5901, 5900 and 5902 all without success.

There is no notification when I actually log onto the remote machine
other than what I normally receive. If I try: 'startx', all I get is a
lot of text output on the screen, although the application does start on
the remote PC.

Now, I can make a connection via HTTP and do get a login box. In fact,
that seems to be the only way I can make a successful connection.
Therefore, I am positive the VNC is working, just not with putty.

Obviously I am doing something really stupid.



More information about the freebsd-questions mailing list