Very Annoying PHP Errors

Alain Wolf wolf at
Wed Feb 14 12:39:48 UTC 2007

On 14.02.2007 12:38, * Peter Pluta wrote:
> I recently upgraded to 5.2.1_1. After upgrading (or before not exactly
> sure) I began getting errors ALERT - canary mismatch on efree() - heap
> overflow detected in my Apache logs. Also, certain parts of one of my
> database (mysql) driven sites stopped working. Certain pages just
> stopped working, they return a blank white page. I'm absolutely stumped
> on what it could be. I have tried recompiling php 4-5x with different
> options and re-installing apache etc... Nothing is working. I looked for
> php bug reports, and found this one
> but it does not really pertain to me. Can anyone give some pointers or
> tips on what to do?
> Right now I am thinking of just downgrading to PHP 5.2.0 because that's
> what worked last. Is there an easy way to downgrade ports?
> Any feedback, tips, or help would be greatly appreciated.
> Thanks,
> Peter
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

My php installations have also several and repeating errors, but its
difficult to analyze, because they keep changing.

While updating ports using portmanager or portmaster sometimes
installation of databases/php5-mysql or databases/php5-mysqli fails or
sometimes both but also sometimes both install without errors.

When errors occur, it has to do with missing mysql-client libraries, a
mysql-client port-installation is attempted and fails because
mysql-client is in fact already installed.

By manually deinstalling and reinstalling mysql-client port just before
the php-mysql port and php-mysqli port installation works, but maybe the
next days already same errors occur.

Sometimes all ports installe correctly but afterwards php fails to load
an installed extension (error message refers to missing functions). This
happened once with mysqli-extension, but not mysql and once with
sqlite-extension. Some others too, but I don't recall which ones.
Usually deinstalling and reinstalling the affected extension fixes it.
But there again, I may get the difficulties mentioned above.

So in summary, as a non programming observator, i think somehow
libraries which where successfully installed get lost at some point on
my systems.

More information about the freebsd-questions mailing list