Thunderbird 2.0 dumps core on second file open op (workaround)

Howard Goldstein hg at
Sat Apr 28 13:38:52 UTC 2007

Garrett Cooper wrote:
> Howard Goldstein wrote:
>> Jan Henrik Sylvester wrote:
>>> Michel Le Cocq wrote:
>>>> I think it's a global thunderbird 2 bug, because i have exactly the 
>>>> same trouble ona mac os 10.4 with a binary update.
>>> I do not think it is exactly the same -- see below.
>>>> Howard Goldstein a écrit :
>>>>> Jan Henrik Sylvester wrote:
>>>>>> Drew Sanford wrote:
>>>>>>  > No, but I am seeing it core dump rather strangely. Each time it 
>>>>>> starts
>>>>>>  > up, I can open a file dialog box to save an attachment or attach a
>>>>>>  > file one time just fine. The second time I try to attach or save a
>>>>>>  > file on any start up, it crashes.
>>>>>> BTW: Firefox 2.0.X does the same. Use "Save Link As..." a few 
>>>>>> times in a row (2 is usually sufficient) and have a core dump.
>>>>>> I had this happen with Firefox 2.0.X and Thunderbird 2.0.0 that I 
>>>>>> compiled myself as well as with this one (on 6.2-RELEASE): 
>>>>>> I guess someone should file a bug report...
>>>>> Looks like the same problem at ports/105589, perhaps it needs to be 
>>>>> reopened, seems to be the same problem.  Haven't tried the 
>>>>> workaround. Not sure how to do that on someone else's gnats.  (cc 
>>>>> to the gnats person who closed it)
>>> After reading the discussion in the PR, I renamed and 
>>> tried again: no crashes with Firefox 2.0.3 or Thunderbird 2.0.0. I do 
>>> run KDE -- I probably should compile Firefox and Thunderbird without 
>>> the gnome dependencies to solve it for me.
>> I wish I'd googled for KDE along with this as the problem was 
>> apparently fixed once for KDE, although for some reason came back 
>> again now for some of us.  Here's a link to the very same bug along 
>> with a fix that was targeted only for KDE
>> Based on your find Jan it's fairly simple to workaround this in the 
>> Makefile by disabling gnomeui and gnomevfs linkages.  Here's 
>> my diff which also includes tiny cruft disabling ldap during the build 
>> since I can't build an LDAPable thunderbird2 on my system.
>> (before the diff, following up, reverting CFLAGS to -O -pipe and the 
>> default CPUTYPE didn't help, neither did installing gnome2)
>> ------------------------------------------------------------------------
>> *** mail/thunderbird/Makefile.orig    Fri Apr 27 18:00:27 2007
>> --- mail/thunderbird/Makefile    Fri Apr 27 19:15:58 2007
>> ***************
>> *** 17,23 ****
>>   COMMENT=    Mozilla Thunderbird is standalone mail and news that 
>> stands above
>>     CONFLICTS=    lightning-0.[0-9]*
>> ! WANT_GNOME=    yes
>>   ALL_TARGET=    default
>>   HAS_CONFIGURE=    yes
>> --- 17,25 ----
>>   COMMENT=    Mozilla Thunderbird is standalone mail and news that 
>> stands above
>>     CONFLICTS=    lightning-0.[0-9]*
>> ! #hgWANT_GNOME=    yes
>> ! WANT_GNOME=    no
>> ! #hg
>>   ALL_TARGET=    default
>>   HAS_CONFIGURE=    yes
>> ***************
>> *** 31,36 ****
>> --- 33,41 ----
>>   MOZ_GRAPHICS=    default,-xbm
>>   MOZ_OPTIONS=    --enable-single-profile --disable-profilesharing    \
>>           --enable-application=mail --enable-official-branding
>> + #hg
>> + MOZ_OPTIONS+=    --disable-ldap  --disable-gnomeui --disable-gnomevfs
>> + #hg
> Based on someone's comments about OSX though, there might be an issue 
> with the underlying base system or kernel in FreeBSD <6.2 that 
> Thunderbird 2 unearths, dealing with filesystem handling, threading, 
> linking, or something along those lines (I know, that really doesn't 
> narrow down the list). It should be a core component though because 
> Thunderbird under OSX doesn't have any GTK or X11 support compiled in 
> and is natively run under Aqua.
> I'll look for the core dump sent previously, but if more people can 
> contribute their core dumps this would help isolate the issue. The 
> bigger (and compressed) the better, as long as you don't have sensitive 
> data hanging around in the background. This might just help capture the 
> problem at hand.
> Hardware specs and CPUTYPE, as well as whether or not you're running a 
> custom or generic kernel with what options would help as well. Please 
> link off site if you can.
> After that maybe we should all band together and submit a bug report.
> Now let me see if I can reproduce it on my iBook :).

Yes I think we need to continue on fixing this since my rotten stinking 
workaround doesn't workaround for long anyway.  Thunderbird survived a 
few additional attachments than before, but still dumped a core this 
morning after idling all night when I attempted to attach the files 
indicated below to this very email  :(

Here are some additional details:

- sys is an Asus P4P800, two SATA drives in RAID1 config using the
onboard ICH5 controller, a crappy IDE winchester and a crappy IDE CDROM,
- dmesg (non debug, sorry) and log attached

Let me know if I can send along anything else.  Bizarre, isn't it?
While googling I saw a fleeting note that pthreads were suspected and
darned if it doesn't die in there.

-------------- next part --------------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-STABLE #0: Fri Apr 27 16:25:16 EDT 2007
    hg at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 2.60GHz (2598.76-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
  Logical CPUs per core: 2
real memory  = 1609760768 (1535 MB)
avail memory = 1559896064 (1487 MB)
acpi0: <A M I OEMXSDT> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
nvidia0: <GeForce FX 5600> mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff irq 10 at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]
uhci0: <Intel 82801EB (ICH5) USB controller USB-A> port 0xd480-0xd49f irq 10 at device 29.0 on pci0
usb0: <Intel 82801EB (ICH5) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801EB (ICH5) USB controller USB-B> port 0xd800-0xd81f irq 15 at device 29.1 on pci0
usb1: <Intel 82801EB (ICH5) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801EB (ICH5) USB controller USB-C> port 0xd880-0xd89f irq 11 at device 29.2 on pci0
usb2: <Intel 82801EB (ICH5) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <Intel 82801EB (ICH5) USB controller USB-D> port 0xdc00-0xdc1f irq 10 at device 29.3 on pci0
usb3: <Intel 82801EB (ICH5) USB controller USB-D> on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801EB/R (ICH5) USB 2.0 controller> mem 0xf5fffc00-0xf5ffffff irq 5 at device 29.7 on pci0
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801EB/R (ICH5) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <network, ethernet> at device 5.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH5 UDMA100 controller> port 0xc080-0xc087,0xc000-0xc003,0xbc00-0xbc07,0xb880-0xb883,0xb800-0xb80f irq 11 at device 31.1 on pci0
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
atapci1: <Intel ICH5 SATA150 controller> port 0xcc00-0xcc07,0xc880-0xc883,0xc800-0xc807,0xc480-0xc483,0xc400-0xc40f irq 11 at device 31.2 on pci0
ata4: <ATA channel 0> on atapci1
ata5: <ATA channel 1> on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
pcm0: <Intel ICH5 (82801EB)> port 0xd000-0xd0ff,0xd400-0xd43f mem 0xf5fff800-0xf5fff9ff,0xf5fff400-0xf5fff4ff irq 14 at device 31.5 on pci0
pcm0: <Analog Devices AD1985 AC97 Codec>
acpi_button0: <Power Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppi0: <Parallel I/O> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
ums0: Logitech USB-PS/2 Optical Mouse, rev 2.00/27.10, addr 2, iclass 3/1
ums0: 8 buttons and Z dir.
Timecounter "TSC" frequency 2598762436 Hz quality 800
Timecounters tick every 1.000 msec
ad5: 156334MB <Maxtor 6Y160P0 YAR41BW0> at ata2-slave UDMA100
acd0: CDROM <FX5401W/U01F> at ata3-master UDMA33
ad8: 190782MB <MAXTOR STM3200820AS 3.AAE> at ata4-master SATA150
ad10: 190782MB <MAXTOR STM3200820AS 3.AAE> at ata5-master SATA150
ar0: 190782MB <Intel MatrixRAID RAID1> status: READY
ar0: disk0 READY (master) using ad8 at ata4-master
ar0: disk1 READY (mirror) using ad10 at ata5-master
Trying to mount root from ufs:/dev/ar0s1a
skc0: <3Com 3C940 Gigabit Ethernet> port 0xe800-0xe8ff mem 0xf7ffc000-0xf7ffffff irq 10 at device 5.0 on pci2
skc0: 3Com Gigabit LOM (3C940) rev. (0x1)
sk0: <Marvell Semiconductor, Inc. Yukon> on skc0
sk0: Ethernet address: 00:0c:6e:60:96:2a
miibus0: <MII bus> on sk0
e1000phy0: <Marvell 88E1011 Gigabit PHY> on miibus0
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-FDX, auto
ipfw2 (+ipv6) initialized, divert loadable, rule-based forwarding disabled, default to deny, logging disabled
sk0: link state changed to UP
nfs server pid549 at cally:/n: not responding
nfs server pid549 at cally:/n: not responding
nfs server pid549 at cally:/n: not responding
nfs server pid549 at cally:/n: is alive again
pid 66184 (thunderbird-bin), uid 1000: exited on signal 11 (core dumped)
pid 10969 (thunderbird-bin), uid 1000: exited on signal 11 (core dumped)

More information about the freebsd-questions mailing list