Thunderbird 2.0 dumps core on second file open op (workaround)

Garrett Cooper youshi10 at
Sat Apr 28 05:14:59 UTC 2007

Howard Goldstein wrote:
> Jan Henrik Sylvester wrote:
>> Michel Le Cocq wrote:
>>> I think it's a global thunderbird 2 bug, because i have exactly the 
>>> same trouble ona mac os 10.4 with a binary update.
>> I do not think it is exactly the same -- see below.
>>> Howard Goldstein a écrit :
>>>> Jan Henrik Sylvester wrote:
>>>>> Drew Sanford wrote:
>>>>>  > No, but I am seeing it core dump rather strangely. Each time it 
>>>>> starts
>>>>>  > up, I can open a file dialog box to save an attachment or attach a
>>>>>  > file one time just fine. The second time I try to attach or save a
>>>>>  > file on any start up, it crashes.
>>>>> BTW: Firefox 2.0.X does the same. Use "Save Link As..." a few times 
>>>>> in a row (2 is usually sufficient) and have a core dump.
>>>>> I had this happen with Firefox 2.0.X and Thunderbird 2.0.0 that I 
>>>>> compiled myself as well as with this one (on 6.2-RELEASE): 
>>>>> I guess someone should file a bug report...
>>>> Looks like the same problem at ports/105589, perhaps it needs to be 
>>>> reopened, seems to be the same problem.  Haven't tried the 
>>>> workaround. Not sure how to do that on someone else's gnats.  (cc to 
>>>> the gnats person who closed it)
>> After reading the discussion in the PR, I renamed and 
>> tried again: no crashes with Firefox 2.0.3 or Thunderbird 2.0.0. I do 
>> run KDE -- I probably should compile Firefox and Thunderbird without 
>> the gnome dependencies to solve it for me.
> I wish I'd googled for KDE along with this as the problem was apparently 
> fixed once for KDE, although for some reason came back again now for 
> some of us.  Here's a link to the very same bug along with a fix that 
> was targeted only for KDE
> Based on your find Jan it's fairly simple to workaround this in the 
> Makefile by disabling gnomeui and gnomevfs linkages.  Here's my 
> diff which also includes tiny cruft disabling ldap during the build 
> since I can't build an LDAPable thunderbird2 on my system.
> (before the diff, following up, reverting CFLAGS to -O -pipe and the 
> default CPUTYPE didn't help, neither did installing gnome2)
> ------------------------------------------------------------------------
> *** mail/thunderbird/Makefile.orig	Fri Apr 27 18:00:27 2007
> --- mail/thunderbird/Makefile	Fri Apr 27 19:15:58 2007
> ***************
> *** 17,23 ****
>   COMMENT=	Mozilla Thunderbird is standalone mail and news that stands above
>   CONFLICTS=	lightning-0.[0-9]*
> ! WANT_GNOME=	yes
>   ALL_TARGET=	default
> --- 17,25 ----
>   COMMENT=	Mozilla Thunderbird is standalone mail and news that stands above
>   CONFLICTS=	lightning-0.[0-9]*
> ! #hgWANT_GNOME=	yes
> ! WANT_GNOME=	no
> ! #hg
>   ALL_TARGET=	default
> ***************
> *** 31,36 ****
> --- 33,41 ----
>   MOZ_GRAPHICS=	default,-xbm
>   MOZ_OPTIONS=	--enable-single-profile --disable-profilesharing	\
>   		--enable-application=mail --enable-official-branding
> + #hg
> + MOZ_OPTIONS+=	--disable-ldap  --disable-gnomeui --disable-gnomevfs
> + #hg

Based on someone's comments about OSX though, there might be an issue 
with the underlying base system or kernel in FreeBSD <6.2 that 
Thunderbird 2 unearths, dealing with filesystem handling, threading, 
linking, or something along those lines (I know, that really doesn't 
narrow down the list). It should be a core component though because 
Thunderbird under OSX doesn't have any GTK or X11 support compiled in 
and is natively run under Aqua.

I'll look for the core dump sent previously, but if more people can 
contribute their core dumps this would help isolate the issue. The 
bigger (and compressed) the better, as long as you don't have sensitive 
data hanging around in the background. This might just help capture the 
problem at hand.

Hardware specs and CPUTYPE, as well as whether or not you're running a 
custom or generic kernel with what options would help as well. Please 
link off site if you can.

After that maybe we should all band together and submit a bug report.

Now let me see if I can reproduce it on my iBook :).


More information about the freebsd-questions mailing list