Error from mount_smbfs

Scott D Friedemann scott at
Fri Apr 27 01:39:23 UTC 2007

Lowell Gilbert wrote:
> I tracked it as far as an ioctl call for creating what looks like a
> protocol block.  I don't have the time to trace into the kernel right
> now, and it doesn't look like anything in the smbtools userland has
> changed in quite a while.
> Can we assume that you checked the obvious things, like making sure
> that the system isn't running out of memory?  Does this happen with a
> GENERIC kernel?  Are you sure the kernel matches the userland?  Also
> let us know if you can recall when it stopped working.
> And for what it's worth, I don't get such an error on -STABLE.

I decided to update sources (still patch level 3), build world and the 
GENERIC kernel and see what happens.  No change.  Same error.  This will 
occur logging in as root to a console on a machine with 1GB RAM, so 
memory is not an issue.  Building my custom kernel, which has very 
little customization, yields the same error as before, too.

I last used this successfully 16 February 2007.

More information about the freebsd-questions mailing list