Samba connection fails

L Goodwin xrayv19 at
Tue Apr 24 21:06:09 UTC 2007

It looks like a network configuration issue (haven't done any net config on a UNIX box in 10-15 years). When I run "smbclient -L localhost", I get:

 Password: (pressed <ENTER>)
Anonymous login successful
Anonymous login successful
Domain=[OFFICE] OS=[Unix] Server=[Samba 3.0.23c]

    Sharename    Type    Comment
    ----------------    -------    ---------------
    sambavol        Disk
    IPC$                  IPC   IPC Service (Samba 3.0.23c)

Anonymous login successful
 Domain=[OFFICE] OS=[Unix] Server=[Samba 3.0.23c]
    Server            Comment
    ---------            --------------

    Workgroup    Master
    ---------------    -----------

What next? I want to get this server as ready as possible before carting it to client location. Thanks!

L Goodwin <xrayv19 at> wrote: I installed the samba-3.0.23c_2,1 package on a server destined for a small office network running Windows clients. Have not yet configured the network settings.
Am trying to test the Samba configuration "offline" before connecting it to the network (router connected to cable modem, clients connected to router via Cat-5e Ethernet).

Issues/Questions (see Samba configuration details at end of email):

1) "smbclient -L " fails with "Connection to SERVER failed".
Get same error for "smbclient //SERVER/sambavol". What does this mean?

2) What value to assign "netbios name" in smb.conf?

3) What degree of network configuration is necessary for "smbclient -L " to work?

4) How to verify that Samba3 package was installed successfully (other than lack of warnings/errors during install)?


1) Create smb.conf file in /usr/local/etc:

workgroup = office
netbios name = tbd (is this required, and how/where to get/set it?)
security = share

path = /sambavol
browseable = yes
writeable = yes
printable = no

2) Add entry to start samba in /etc/rc.conf:

3) Start Samba:
    /usr/local/etc/rc.d/samba start
(to stop samba: /usr/local/etc/rc.d/ stop)

Note: Need to keep the file server synced with Internet standard time (see NTPD(8) man page).

1) Verify that smb.conf file is in the right directory (gets read):
    which smbd    # Get location of smbd
    (output: usr/local/sbin/smbd)
    cd /usr/local/sbin    # cd to the directory containing smbd!
    smbd -b | grep smb.conf    # Get location of smb.conf (verify path is correct)
    (output: CONFIGFILE: /usr/local/sbin/smb.conf)

2) Test Samba configuration file:
    cd /usr/local/etc
    testparm smb.conf

3) List shares available on server: 
    smbclient -L 
RESULT: FAIL ("Connection to SERVER failed")

Additional Samba Configuration Steps:
1) Uncommented the following lines in /etc/inetd.conf and rebooted:
    #netbios-ssn    stream    tcp    nowait    root    /usr/local/sbin/smbd    smbd
    #netbios-ns    dgram    udp    wait    root    /usr/local/sbin/nmbd    nmbd
On reboot, get these boot messages:
Removing stale Samba tdb files: ...... done
Starting nmbd.
Starting smbd.
Starting usbd.
RESULT: Still getting "Connection to SERVER failed".

Ahhh...imagining that irresistible "new car" smell?
 Check outnew cars at Yahoo! Autos.
freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Ahhh...imagining that irresistible "new car" smell?
 Check outnew cars at Yahoo! Autos.

More information about the freebsd-questions mailing list