CUPS + FreeBSD 6.2 + HP Laserjet 5

Jim Stapleton stapleton.41 at
Fri Apr 20 22:08:50 UTC 2007

I'm trying to print a test page for my printer using cups and I get
the following error:
Unsupported format 'application/postscript'!

I couldn't find anything when googling with FreeBSD in my search. When
I took out FreeBSD, I got something for debian referencing lines 103
and 109 in the config being uncommented to get it to work. 103 in the
default is blank, 109 is blank except for teh '#'.

I uncommented this line, and restarted CUPS:
application/vnd.cups-postscript	application/vnd.cups-raster	100	pstoraster

It didn't fix anything.
I added this line, and restarted:
application/postscript	application/vnd.cups-raster	100	pstoraster

And I still get the same error.

I know CUPS worked fine from an install maybe 6 months ago (it had a
completely different printer setup than now, it wasn't as easy to
setup, but at least it worked).

My question
(1) Anyone know how to fix this issue with the current version
(cvsup'ed and built today via 'sudo portupgrade -f
print/cups-pstoraster print/cups-base print/ghostscript-gnu*
(2) How do I get csup/cvsup to match one port or a group of ports by
name? I put *default date=2006. in my supfile
(etc/supfile-ports) and tried:
sudo csup -i '*cups*' -L 2 /etc/supfile-ports
sudo csup -i 'print/cups*' -L 2 /etc/supfile-ports
sudo cvsup -g -i '*cups*' -L 2 /etc/supfile-ports
sudo cvsup -g -i 'print/cups*' -L 2 /etc/supfile-ports

and none of the above updated any files according to the output (I
usually see a list of files updated). Since ports were updated this
morning, without the date line (so to today's ports layout), I should
have seens something.

-Jim Stapleton

More information about the freebsd-questions mailing list