nspluginwrapper + native firefox 2 + flash9?

Ghirai ghirai at ghirai.com
Fri Apr 13 01:34:56 UTC 2007

Hello John,

Thursday, April 12, 2007, 9:48:34 AM, you wrote:

> Hi everybody, I've been struggling with this all night and the archives +
> google aren't coming up with much except for other people's success stories.

> I recently ditched using the linux-firefox port in favor of the native version
> when I read a post about nspluginwrapper. I've spent the last 2 days upgrading
> many ports on my system. I think I've got things A-OK, but I cannot get
> nspluginwrapper to do anything meaningful with the native firefox.

> My config:

>  6.2-STABLE as of april 10th
>  CVSup'ed ports tree as of April 10th
>  linux_base-fc-4_9 installed--do I need fc-6??
>  linux-alsa-lib- also installed
>  firefox-,1 compiled and installed
>  linux-flashplugin9 installed 

> I did the following:

>   % nspluginwrapper -v -i
> /usr/X11R6/lib/linux-mozilla/plugins/libflashplayer.so

> saw:

> Install plugin /usr/X11R6/lib/linux-mozilla/plugins/libflashplayer.so
>   into /usr/local/lib/browser_plugins/npwrapper.libflashplayer.so

> after firing firefox back up and doing about:plugins I see what I hoped to see:

>    Shockwave Flash
>        File name: npwrapper.libflashplayer.so
>        Shockwave Flash 9.0 r31
>    MIME Type    Description     Suffixes        Enabled
>    application/x-shockwave-flash        Shockwave Flash         swf Yes
>    application/futuresplash     FutureSplash Player     spl     Yes

> However whenever I visit a site that utilizes Flash, nothing shows up--not even
> an 'outline' of what should be a flash file playing. 

> I've tried using nspluginwrapper -r to uninstall the plugin and use
> linux-flashplugin7 but the results are the same. I've also tried using
> linux-mplayer-plugin which yielded similar results: about:plugins showed a
> plethora of MIME type's, descriptions, etc. but no dice.

> Does anybody have any clues as to what's going wrong or things I could possibly
> try? From all accounts seen via google, this has "just worked" for people ... :(

> Thanks in advance.

> -Jr

I'm using konqueror with flash, and i followed this howto

I know you were looking for a way to get FF to work,
but i gave up, and konqueror is working fine for me.

Best regards,

More information about the freebsd-questions mailing list