ipfw fwd not working in 6.2-release

Jonathan McKeown jonathan at hst.org.za
Thu Apr 5 13:58:42 UTC 2007

> On Thursday 05 April 2007 15:42, Terry Todd wrote:
> > On Tue, Apr 03, 2007 at 10:58:41AM -0500, Terry Todd wrote:
> > I have tried to get ipfw fwd to work in 6.2-release but it always barfs.
> >
> > I have recompiled and installed a custom kernel with
> > options         IPFIREWALL_FORWARD

[adding a fwd rule]

> > ipfw: getsockopt(IP_FW_ADD): Invalid argument


> > Anyone else see this behaviour?

> I tried this on a second machine and it does the same thing.
> ipfw: getsockopt(IP_FW_ADD): Invalid argument
> Could someone try running this on a 6.2-RELEASE system and tell me what you
> get:
> # ipfw add forward,3128 tcp from not me to any 80 in via
> [interface device]

I'm seeing the same thing having just upgraded a working 6.0-RELEASE box. 
Since the only kernel option I had set on either version of the OS was 
IPFIREWALL_FORWARD, the system is loading ipfw.ko, ipdivert.ko and 
dummynet.ko automatically.

Has the way ipfw.ko is built changed? Do we need to compile ipfw into the 
kernel to use ipfw fwd rules now? Or can I force ipfw.ko to be rebuilt with 
forwarding included?


More information about the freebsd-questions mailing list