systat -vm not seeing /dev/acd0

Ian Smith smithi at
Tue Oct 31 08:58:33 UTC 2006

Hardly a showstopper, but ..

Burned a backup CD on a 4.10-RELEASE system downtown; no problem.

Being important, I checked by mounting it (/dev/acd0) and running 'cat
/cdrom/* >/dev/null' which was useful verification given all were big
compressed files in the CD's root directory.

That was taking a while so I ran systat -vm in another vty, watched it
reading away at about 2MB/s, more or less as expected from that drive.

Got home and (being important) checked it by the same method on a 6.1-R
GENERIC system (no /dev/cd0, only acd0 in dmesg).  systat -vm showed no
acd0 device, just ad0.  man systat, tried the :drives command; just ad0

Tried again on a 5.5-S @1stAug system.  systat -vm also didn't see acd0,
though due to atapicam, scbus & pass in kernel, showed it once remounted
on /dev/cd0 - 'Disks ad0 da0 cd0 pass0 pass1'.  Same issue with iostat.

Copying the CD to ad0 implied the reading rate of course (~3.5MB/s) so
that's a workaround for the 6.1-R system, but should I be surprised that
{sys,io}stat can't see acd0 as it used to on 4.X?  Anything that would?

Cheers, Ian

More information about the freebsd-questions mailing list