problems after rebuild of 5.5 stable

Matthew Pope mpope at
Sun Oct 22 11:44:42 UTC 2006

Added to my original problem description the full list of WARNING 
messages from boot:
BTW, my FreeBSD 5.5 is running on a Pentium 4/2.4 GHz, 512 M RAM, Asus 
mother board, oodles of disk

Matthew Pope wrote:

> Hello,
> I have a bit of grey hair, but I've been blessed with working with 
> FreeBSD gurus so much that I am struggling to run my own domain and 
> webserver. That is I have have been co-dependant upon FreeBSD gurus in 
> the past, so I was lazy. I'm now on my own and finding that 
> administering a UNIX system based domain and webserver is rewarding, 
> but requires a lot of technical knowledge.
> The root of my problem was my 5.4 based system was running out of 
> sockets due to a close early problem, and a problem description I read 
> in the mailing lists did describe something very close, for which the 
> discoverer of the problem provided a patch. Rather than patch, I 
> thought it that since it's been a year, it was time to rebuild the 
> kernel with the latest STABLE release.  So I did the rebuild as 
> instructed in the FreeBSD Handbook.  Now I'm up to 5-5 STABLE using a 
> default kernel Generic i386 version.
> The mergemaster step following the rebuild and reboot took me for a 
> ride. Rather I rode free and easy not quite sure what I was doing.  I 
> was not sure exactly which file to go with, and I tended to choose t 
> for temp file for many of the prompts.  Now my 5.5 kernel boots, but 
> there are a number of messages of the form:
> source_rc_confs: not found
> $ipnat_enable is not set properly - see rc.conf(5)
> $ipfs_enable is not set properly - see rc.conf(5)

same message as above but with these additional var names:

> etc....
> My rc.conf includes:
> routed_enable="YES"
> router="/sbin/routed"
> defaultrouter=""
> I later read in the mailing list that someone had a simliar problem 
> and solved it by re-running the mergemaster step.  I tried that too, 
> and this time I selected <default> answer to all the prompts about 
> conflicts.  I rebooted, but I still cannot even ping my gateway, as 
> I'm getting "no route to host".
> I tried starting routed manually, but still no routes were 
> discovered.  I also tried inserting a subroutine into rc.subr that 
> called source_rc_confs that did source the rc.confs, and it is called 
> during boot I see from /var/messages.  But alas this is a desperate 
> measure, there must be something I can do to fix this problem without 
> meddling in rc.subr.  So my routing is down, which means my dns is 
> down, and most definetely my httpd is down.
> Any help in debugging, resolving this poorly executed upgrade would be 
> very welcome.
> Thanks,
> Matthew
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list