Broken partition table

Kyrre Nygård kyrreny at
Wed Oct 18 16:42:07 UTC 2006


My partition table is messed up. I have a 150 gigabyte S-ATA hard drive, with a single NTFS partition running Windows XP. I've been running gpart /dev/ad0 for the last 14 hours now and it's not saying anything. I just want to get my data back. I don't care if I have to reinstall everything.

How it all came about is a long story. I ran a second hard disk drive, with FreeBSD, and GRUB so it could do my dual booting. But I needed the space, so I formatted it to NTFS from Windows XP. That's it really, after that, it wouldn't boot. Couldn't load NTLDR.

That's when I tried a lot of different things. boot0cfg, fixmbr and fixboot. I even managed changing its system ID type to FAT using fdisk -- I wasn't thinking clearly -- I was in deep shock. I have also tried gpart from Knoppix, but all its guesses came out as zero. I've also tried running gpart from Insert, another Linux distribution, but it totally freaked out about some I/O stuff. Linux uses SCSI drivers for S-ATA though. 

Is my only choice now to keep running gpart, even if it will run forever?

All suggestions welcome, please!

Best regards,

More information about the freebsd-questions mailing list