emulators/qemu: crashes with "Bad system call: 12"

martinko gamato at users.sf.net
Sun Nov 12 00:45:07 UTC 2006

Josh Carroll wrote:
>> I'm trying to install Win2K but QEMU is constantly crashing with:
>> Bad system call: 12
> According to the qemu man page, there is an option you need when
> installing windows 2000. I don't know if it'd cause the bad system
> call message, but it's worth a shot. Also, I think the newer qemu port
> require aio (kldload aio, if it's not built into your kernel).
>       -win2k-hack
>           Use it when installing Windows 2000 to avoid a disk full
> bug. After
>           Windows 2000 is installed, you no longer need this option (this
>           option slows down the IDE transfers).
> Give that a shot.
> Josh
>> The command line I'm using is a variation of the following:
>> qemu -cdrom /opt/win2k.iso -hda /opt/c.img -m 256 -boot d -win2k-hack
>> First I tried to boot directly from CD.  Also I used QCOW disk image but
>> QEMU crashed at a very early stage (before Win2K installer kicked in).
>> Now I'm using RAW disk image and QEMU actually runs up to after initial
>> Win2K installer reads device configuration files.
>> What might be wrong and how to fix it please ?
>> Cheers,
>> Martin
>> PS: QEMU is freshly installed from ports on FreeBSD 6.2-PRERELEASE.


i tried that win2k option and qemu still fails with or without it. :-/

i loaded up aio(4) module and while displaying the following ...

Nov 12 01:24:38 mb-aw1n-bsd kernel: WARNING: Network stack Giant-free,
but aio requires Giant.
Nov 12 01:24:38 mb-aw1n-bsd kernel: Consider adding 'options
NET_WITH_GIANT' or setting debug.mpsafenet=0

... it actually helped my case and now i'm curiously installing
winblows.. ;o)

many thanks !!


ps: i'm cc-ing the lists for archives.

More information about the freebsd-questions mailing list