Need help restoring from filesystem failure

Lowell Gilbert freebsd-questions-local at
Wed Jun 28 15:33:32 UTC 2006

Maxim Vetrov <muxas at> writes:

> I'm running 6.1 release compiled from source. For a half of june it
> run smoothly. But then somehow I got a filesystem crash - it just
> refused to start after reaching fstab mounts, saying that fs (/data)
> was not properly dismounted:
> ...
> WARNING: /data was not properly dismounted
> /data: bad dir ino 2 at offset 16384: mangled entry
> panic: ufs_dir_bad: bad dir
> ...
> I rebooted in single user mode and run fsck -f on each filesystem. All
> but one were clean.  I agreed on automatic correction suggested by
> fsck (shame on me, I do not remember what the message was about). Fsck
> applied suggested change and marked fs as clean. Then I tried to mount
> the fs:
>> mount /dev/ad0s1f /data
> Instead I got complains about not properly dismounting and page fault
> while at kernel mode (page not present).
> I run fsck one more time (it didn't find any problem this time) and
> rebooted the system. The first problem showed up. Now I have vicious
> circle: mangled entry and page fault.

The disk itself is probably having serious problems.  I would try
copying the whole filesystem.  dd(1) with conv=noerror may be a good

> Is there any way to correct the problem? I was not so "excited" if it
> had been /var or even /usr, but it was /data with all of my personal
> projects and I do not have backups!!!

That is a rather unfortunate error.

More information about the freebsd-questions mailing list