problem creating filesystem snapshot

Nikos Vassiliadis nvass at
Fri Jun 23 09:26:08 UTC 2006

On Thursday 22 June 2006 21:04, Jon Falconer wrote:
> Greetings,
> I needed to dump the partitions on a running FreeBSD 6.1R system so I
> could duplicate them on a test server. The server is a Dell 2850 with the
> PERC 4e/Di RAID controller with 5 x 73GB disk array. So I thought I would
> try using the snapshot feature. I used the mksnap_ffs to create a snapshot
> of a 20GB partition. The command completed in about 15 - 20 seconds. I was
> then able to run dump against the new snap file and all seemed ok. I then
> tried the same thing on a 225GB partition. The mksnap_ffs command took
> over 30 minutes to complete. But every access to that partition after that
> just hung. I wanted to see the size of the snap file so I typed ls -l
> /home/.snap (where I had told mksnap_ffs to put the snap file) and it
> hung. Same thing from several logins. I figured I would have to reset the
> box so I typed sync, and that hung. All the time, access to other
> partitions was just fine (/, /usr, /var).
> All partitions (except /) were created with soft update enables (default
> when installing.)
> The questions. Is there anything magic about the /xxx/.snap directory in
> each partition? When I created the snap file for the 20GB partition, I did
> not put it inside the /xxx/.snap directory, and it worked fine.

No, there is no magic in .snap directories. You can create a snapshot
anywhere you want. You can find all snapshots in a UFS with the
snapinfo(8) utility.

> Is there 
> some partition size restrictions?

Can't answer this question, but there are a few commits after 6.1-RELEASE
so you can try updating to 6.1-STABLE and see what's going on.

Also, why don't you ask freebsd-fs@?

More information about the freebsd-questions mailing list