Python port problems

Alex Zbyslaw xfb52 at
Sun Jun 18 17:28:55 UTC 2006

Joe Auty wrote:

> On Jun 15, 2006, at 6:16 AM, Alex Zbyslaw wrote:
>> Joe Auty wrote:
>>> jauty# python -v /usr/local/mailman/bin/qrunner
>>> [...snip...]
>>> # /usr/local/lib/python2.4/getopt.pyc matches /usr/local/lib/  
>>> python2.4/
>>> import getopt # precompiled from /usr/local/lib/python2.4/getopt.pyc
>>> # /usr/local/mailman/bin/paths.pyc matches /usr/local/mailman/bin/  
>>> import paths # precompiled from /usr/local/mailman/bin/paths.pyc
>>> [...snip...]
>> OK, you just ran qrunner successfully without getting the error you  
>> were getting earlier about getopt.  Doesn't matter that all you got  
>> was help, it found *everything* that it tried to import.
>> I missed the start of this thread.  How did you run qrunner to get  
>> your earlier error and where did the error appear?  I think you  said 
>> the rc script.  If it's not too big can you post it?  Or  compare it 
>> against your working mailman?
> My Mailman rc script (exactly identical to the one on my working  
> machine):
You're getting your error when mailman starts at boot time; is that right?

If so, what happens if you try as root (csh):

# sh -x /usr/local/etc/rc.d/ start


# sh -x /usr/local/etc/rc.d/ start

(you might have to check the exact name of the rc.d script).

If this starts mailman then something bizarre is going on.

If you get the same error as usual, then judicious snippets with the 
error and prior context.


More information about the freebsd-questions mailing list