Makefile for rpm-4.0.4_4

solsyst at solsyst at
Mon Jun 5 12:02:22 PDT 2006

Hi LG:
Thanks for the tip.

I connected to www., sherched for rpm and got to a page 
with several rpm ports that can be downloaded. Since O have FreeBSD 6.0 
I figured I could go for the latehast rpm which is 4.0.4_4. So I first 
downloaded rpm4.tar, and put it in my /usr/rpm/rpm4/ dir. rpm4.tar 
contains the makefile.Then I downloaded rpm-4.0.4_4.tbz and put it in 
my /usr/ports/ dir. But I could see that the make file was not 
interested in a tbz file so I connected to the internet and started 
make so it coul;d go get the file it wanted. Make did so.

I think I also unzipped the rpm-4.0.4_4 tbz file. Somehow I ended up 
with two sub-directories to my /usr/rpm/rpm4 directory They are Files 
and Work. The files Dir contains a bunch of patch files.

 From what you said about "a patch in the port skeleton which isn't 
appropriate to the
source that had been un-tarred from rpm-4.0.4.tar.gz.", perhaps I 
should delete everything and start over with just the rpm4.tar file in 
my /usr/rpm/rpm4/ dir. Am I correct in thinking that the only file I 
need to untar is rpm4.tar, and when I execute the extracted make file 
and there is no other rpm stuff in my directories, MAKE INSTALL should 


Do I have any other options with the unzipped rpm-4.0.4_4.tbz mess 
already created?

-----Original Message-----
From: Lowell Gilbert <freebsd-questions-local at>
To: RAW <solsyst at>
Cc: freebsd-questions at; glewis at
Sent: Mon, 05 Jun 2006 10:32:49 -0400
Subject: Re: Makefile for rpm-4.0.4_4

  RAW <solsyst at> writes:

> This question is about a FreeBSD port that I cannot automake.
> Dear FreeBSDers;
> Tried to obtain, make and install Port rpm-4.0.4_4, on my new FreeBSD
> 6.0. Not there yet Looks like the Makefile program got down to
> "post-patch:", became unhappy, informed me with error code 127, (???)
> and quit.Make claimed that it could not find the shell script
> "configure" (see log below), but when I follow the path to the file,
> there it is. It left an "extract done.rpm-4" doc empty.
> How can I get the makefile to continue, find "configure" and finish
> the make job?
> P.S. I ran Make in a terminal window on my KDE desktop. Matters?
> Thanks for the help.
> Make log:
> /usr/rpm/rpm4
> # make install clean
> ===>  Vulnerability check disabled, database not found
> => rpm-4.0.4.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
> => Attempting to fetch from
> fetch: File
> unavailable (e.g., file not found, no access)
> => Attempting to fetch from
> rpm-4.0.4.tar.gz                              100% of 5728 kB 2370
> Bps 00m00s
> ===>  Extracting for rpm-4.0.4_4
> => Checksum OK for rpm-4.0.4.tar.gz.
> ===>  Patching for rpm-4.0.4_4
> ===>  Applying FreeBSD patches for rpm-4.0.4_4
> -e 's:%%LOCALBASE%%:/usr/local:'
> /usr/rpm/rpm4/work/rpm-4.0.4/configure
> /usr/rpm/rpm4/work/rpm-4.0.4/beecrypt/configure
> -e: not found
> *** Error code 127
> Stop in /usr/rpm/rpm4.

You have a patch in the port skeleton which isn't appropriate to the
source that had been un-tarred from rpm-4.0.4.tar.gz.

How did you get your ports skeleton anyway?

Try the New Netscape Mail Today!
Virtually Spam-Free | More Storage | Import Your Contact List

More information about the freebsd-questions mailing list