cannot ping anything

Alvaro J. Gurdián AJGurdian at
Fri Jan 20 12:34:24 PST 2006

I tried both of those and got the same result, ping: sendto: No route 
to host.

I examined my dmesg output a little closer and noticed:
IP Filter: v3.4.35 initialized.  Default = block all, Logging = enabled

This means that my assumption of disabling IPF by removing all of the 
comments tertainin to it and IPNat from /etc/rc.conf were wrong because 
it it compiled statically.  This means that there is no way to turn it 
off, right?

So I reloaded my old /etc.rc.conf with the somments to turn on IPF and 
IPNat, and point to their rules files.

The previous computer this HD was installed on had two NICs sis0 and 

sis0 was connected to the WAN, so I just changed sis0 in all the 
comments to dc0.  I made sure there was a statement that allowed ICMP 
statements thru.

I restarted, and things stayed the same, so I went back to 
/etc/ipf.rules and changed all instances of sis1 to dc0, also maing 
sure the ICMP statement was there.

I restarted again and, once again ,no progress.  Since the previous 
machine had two interfaces this is most likely the issue since nat is 
messing things up.

I have to get moving forward with this project so I am simply 
downloading the new 6.0 release.

This should solve the problem.

Thanks anyway

On Jan 20, 2006, at 2:43 PM, Derek Ragona wrote:

> See if you can ping your own interface.  You should be able to ping it 
> on both the loop back and the address.
> If you can ping those and still not the router at check 
> for other defaultrouter statements.  If you have only one of these 
> statements, I would bring down the interface and bring it up manually 
> until you find the correct settings.  For instance you may need to set 
> the line speed 1t 10 MBs, or 100 MBs or 1000 Mbs, or set the duplex 
> setting.  Oh and check the LED's on your ethernet interface and router 
> and hub/switches to be sure you didn't knock a cable loose.
>         -Derek
> At 12:50 PM 1/20/2006, Alvaro J. Gurdián wrote:
>> thanks, but the defaultrouter line was already present in my 
>> /etc/rc.conf.
>> On Jan 20, 2006, at 1:32 PM, Derek Ragona wrote:
>>> Check your /etc/rc.conf for this line:
>>> defaultrouter=""
>>> add it and reboot if it is missing
>>>         -Derek
>>> At 12:26 PM 1/20/2006, Alvaro J. Gurdián wrote:
>>>> Yesterday I placed an HD with Freebsd 5.3 release in a Dell 
>>>> Dimension L800CXE.  It booted properly. ( since it's running a 
>>>> generic kernel with only a name change)
>>>> However I could not ping anything inside or outside the LAN.
>>>> Ex:
>>>> ping
>>>> ping: cannot resolve Hostname lookup failure
>>>> ping
>>>> ping: sendto: No route to host
>>>> I tried several addresses inside the LAN,, localhost, 
>>>>, and all gave the same result.
>>>> I was previously using this HD in another machine to test IPF, with 
>>>> NAT also, and it worked peerfectly there.
>>>> So just to be safe I erased the contents of /etc/rc.conf, and then 
>>>> used sysinstall to bring up my NIC.  I  chose NO for IPv6, and YES 
>>>> for DHCP.
>>>> That seemed to work correctly, just to be sure I ran ifconfig:
>>>>         options=8<VLAN_MTU>
>>>>         inet netmask 0xffffff00 broadcast 
>>>>         ether 00:80:ad:81:1a:9f
>>>>         media: Ethernat autoselect (100baseTX)
>>>>         status: active
>>>> plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
>>>> lo0: flags=8049<UP,LOOPBACK,SIMPLEX,MULTICAST> mtu 1500
>>>>         inet netmask 0xff000000
>>>> Still, things are looking good; so, I go to another box, log into 
>>>> my router(, and I can see the MAC address of the BSD 
>>>> box on my router.
>>>> However, I still get the same results when I ping as I did above.
>>>> Then I checked the routing tables:
>>>> netstat -r
>>>> Routing Tables
>>>> Internet:
>>>> Destination     Gateway                 Flags   Refs    Use     
>>>> Netif Expire
>>>> default             UGS             0       6
>>>>   dc0
>>>> localhost               localhost                       UH
>>>>   1      37      lo0
>>>> 192.168.1               link#1                  UC              0
>>>>   0      dc0
>>>>     00:0c:41:bd:49:7d       UHLW    1       0       dc0
>>>>   695
>>>>   localhost                       UGHS    0       0
>>>>   lo0
>>>> The output of netstat and ifconfig aboe are from today.  I began 
>>>> having this problem yesterday, and left the box on over night.
>>>> Yesterday's output was different in that the BSD box had a 
>>>> different IP address,  That is fine I understand 
>>>> that the box is communicating with the router and negotiating 
>>>> leases when they expire.  However, why has the gateway to 
>>>> changed from link#1 to the MAC address of my router.  I 
>>>> am certain that if  I restart the computer that same gateway will 
>>>> revert to link#1.
>>>> The my questions are:
>>>> How do I get the system to see others in the network, and 
>>>> vice-versa?
>>>> What should the gateway for be?(which also happens to 
>>>> be my routers address)
>>>> I am hoping it is something simple.  I could just as have easily 
>>>> reinstalled the system and started from scratch, but I wanted to 
>>>> know how to solve this problem.
>>>> Other info that might help:
>>>> less /etc/rc.conf
>>>> ifconfig_dco="DHCP"
>>>> hostname=""
>>>> defaultrouter=""
>>>> less /etc/resolv.conf
>>>> search
>>>> nameserver
>>>> naemserver
>>>> less /etc/hosts
>>>> ::1              localhost
>>>>        localhost
>>>> Thanks in advance
>>>> _______________________________________________
>>>> freebsd-questions at mailing list
>>>> To unsubscribe, send any mail to 
>>>> "freebsd-questions-unsubscribe at"
>>> _______________________________________________
>>> freebsd-questions at mailing list
>>> To unsubscribe, send any mail to 
>>> "freebsd-questions-unsubscribe at"
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-questions-unsubscribe at"
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list