PAE causing system crashes

Kris Kennaway kris at
Tue Jan 17 19:26:09 PST 2006

On Tue, Jan 17, 2006 at 08:38:08PM -0600, Michael Barnett wrote:
> It ran fine when we were only throwing a few dozen qps at it... when  
> we tried to throw about 350qps its way, it was much much slower...  
> slower than our existing server with significantly fewer resources  
> available.
> I never could figure out what the issue was... tried recompiling with  
> different options, allocating more and less memory to mysql (really  
> to innodb as all our tables are innodb), and a number of system  
> tweaks to no avail.
> Are you running it on an opteron, or on a xeon?  I have heard things  
> go much smoother on AMD hardware.

I've used it for mysql benchmarking (using supersmack) on amd hardware
and got quite good performance from it.  I've not used it with a
'real' database on that machine.

> Anyways.. the damage is done.  We are back on i386 and I just need to  
> make it go!    Right now i am just running with the stable non-PAE  
> kernel that limits access to 4G of memory while i work this out.

It could be a driver issue, although since you're not adding drivers
to the PAE config I don't know why this would be.  Still, you could
post your dmesg so that someone might be able to recognize a problem.

Try looking for an updated BIOS.  It could be that your HW has a buggy

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list