PicoBSD Dummynet/bridge errors

Tyler T tylernt at gmail.com
Mon Jan 16 11:35:25 PST 2006


I just did a default installation of FreeBSD 6.0-RELEASE. I ran the
PicoBSD script in an attempt to create a DummyNet floppy, but I got
the following error:
It says I have lots of undefined references such as gctl_getr_handle,
gctl_ro_param, gctl_issue, and gctl_free.

I tried it again and got pretty much the same thing:

Also, if I try to use the menu to edit the kernel or crunch files,
after I edit (whether I change anything or not) and exit vi I get:
Says "rm: /tmp/reply.[UID]: No such file or directory" and dumps me
out of the menu system.

I've used Linux quite a bit but this is my first time with FreeBSD.
Like I said, I just did a default installation of FreeBSD 6.0. Is
there something special I have to do when installing FreeBSD to get
the PicoBSD/DummyNet script to work, or are these bugs? I am logged in
as root.

Alternatively, if someone has a premade DummyNet floppy image with the
'fxp' Intel PCI NIC drivers built into it, that's all I really need.
The prebuilt DummyNet images I've found online are all very old and
don't recognize my Intel PCI NICs.


More information about the freebsd-questions mailing list