Problems with X11 Forwarding

Nikolas Britton nikolas.britton at
Sun Jan 15 09:42:02 PST 2006

On 1/15/06, Aaron Dalton <aaron at> wrote:
> I thought this might be the best place to post the question.  I am
> running FreeBSD5.4-RELEASE.  For the sake of argument, let's say I am
> trying to get the port editors/fte running on my Windows box via an SSH
> tunnel.  I am running WindowsXP, cygwin's X11 server, and PUTTY.  As far
> as I can tell from all my Googling, this should actually be quite simple:
> - openssh is setup on FreeBSD with X11Forwarding=yes
> - I start the cygwin X-server (XWin -ac -multiwindow)
> - Putty is configured to forward X11 sessions
> - I connect via Putty
> - running '$ fte' from the FreeBSD command line should supposedly open
> everything up now on my Windows box, but it does not.
>  From what I understand, when I connect now via Putty the env variable
> DISPLAY should be set.  But it is not (which is the error fte gives me
> when I try to run it).  If I try to manually set the DISPLAY variable (I
> tried localhost:0, localhost:0.0, ip:0, ip:0.0) it still doesn't work.
> editors/fte is fully installed (with X11libs and all that) but I wonder
> if there is more I need installed on the FreeBSD end to make things work.

If you have cygwin installed why use putty? Just fire up xterm and use
ssh -X. You could try this too:

Go sign the native flash for FreeBSD petition:

More information about the freebsd-questions mailing list