how do you install wx-config in FreeBSD?

bob self bobself at
Mon Jan 9 01:10:07 PST 2006

JD Arnold wrote:


Thanks. Things are starting to work. Now that wx-config works a couple more
questions have come up about wxgtk2. I tried building the penguin sample 
comes with wxWidgets. I get a link warning:

/usr/bin/ld: warning:, needed by /usr/X11R6/lib/, 
not found (try using -rpath or

When I try to run it, I get:

/libexec/ Shared object "" not found, required by 

How do I fix this problem? All of my ports are supposed to be up-to-date.

Also, another issue came up when I tried to compile the mediactrl example:

winmain.cpp:88:2: #error "Not all required elements are enabled.  Please 
modify setup.h!"
winmain.cpp:196: error: `wxMediaEvent' has not been declared

How do you do this in FreeBSD if you use portupgrade? Is there a config 
file to turn on the
mediactrl stuff?

I'm compiling with

g++ -I/usr/X11R6/include -c `wx-config --cxxflags` winmain.cpp

# wx-config --cxxflags shows:

-I/usr/X11R6/include/wx-2.6 -DGTK_NO_CHECK_CASTS


More information about the freebsd-questions mailing list