Kernel Compilation...

Crispy Beef crispy.beef at
Wed Jan 4 09:23:49 PST 2006

Nikolas Britton wrote:
> To rule out hardware problems rebuild the generic kernel using the
> virgin GENERIC kernel config file:
> 0. If you've messed with /etc/make.conf change it back to the defaults!
> 1. su
> 2. cd /usr/src/sys/i386/conf
> 3. rm -r ../compile/GENERIC
> 4. config GENERIC
> 5. cd ../compile/GENERIC
> 6. make depend
> 7. make
> 8. make install
> 9. reboot
> If you can't get to step 8 you have a hardware problem (or FreeBSD
> wasn't installed correctly, see step 5 below):

First time I tried this I had another seg fault (error 11) so did a complete 
install from the CD again (kernel developer options).  It failed once during 
that compile, then the second time it worked just fine.  I then did my own 
config cutting out all the stuff I don't need and it's compiled just fine. 

Thinking about it, this is the only time I've got the sources from the CD.  I 
always grabbed them from an ftpe server via sysinstall, maybe the newer 
sources were causing problems like the guys mentioned earlier?

Got a version of MemTest86 running too and that went for a couple of hours 
without any errors showing up, will run it overnight to be sure.

I guess the next thing is to have a go at make buildworld with options in 
make.conf and see if it barfs then.

Thanks for the help. :-)


More information about the freebsd-questions mailing list