FreeBSD 5.4 & 6.0 slow network throughput

Pavel Duda element at
Tue Feb 28 07:13:18 PST 2006

I have upgraded my home "server" to 5.4 from 5.2.1 and after some time 
I've noticed that network throughput is very low (about 4MB/s).

I'm not expert on this field but I have checked some settings (sysctl, 
netstat) and couldn't find anything suspicious. I have second machine 
with almost same configuration so I tried to put there newer version of 
FreeBSD 6.0 but it doesn't help. Now I've tried older version - 4.11 
(only one I have available at this moment on CD) and speed is as it is 
supposed to be (8-9MB/s).

Does somebody has same experience with such behaviour ? I've used 
"clean" systems ie. without kernel modifications and I don't know what 
could cause this (some major change in TCP stack in 5.4+ ? NIC drivers ?).

Test system:
P4, 1.8Ghz, 512MB RAM with Intel EtherExpress 100 & Realtek Gigabit NIC 
(fxp & rl)

FBSD 5.4/6.0:
- avarage net thrput 3.5 - 4.5 MB/s (tested with FTP/Samba)
- netperf reports about 31-34 mbit/s with default settings

FBSD 4.11:
- avarage net thrput 7.5 - 9 MB/s
- netperf reports about 65-66 mbit/s

Testing was done over 100mbit linksys switch, 1Gbit USR switch, 
crosslink cable. Four different machines used as "clients".

Thanks for any advice

More information about the freebsd-questions mailing list