can't cd to /usr/ports/devel/libtool13

Kent Stewart kstewart at
Sun Feb 26 11:01:44 PST 2006

On Sunday 26 February 2006 10:42, Xn Nooby wrote:
> I fixed most of the errors from my upgrade from 6.1 p#1 to 6.1 p#2,
> and in the process apparently upgraded to 6.1 p#3.  I am still
> getting a libtool error.
> Earlier, I did a "make deinstall clean" on all ports that were using
> libtool, and after removing about 10, I thought I had it fixed.  It
> doesn't seem I am able to remove XMMS, though it appears to deinstall
> successfully when I run the command.  Portupgrade still fails.  I'm
> not really sure what it going on at this point.  I tried to do a
> "less /usr/src/UPDATING", but now it doesn't show the entry that was
> in there last night.  An entry for 2/23 about libtool being moved,
> and there not being any easy fix.
> Here is my error:
> -----------------------------------------------------------------
> az# portversion -l "<"
> az# portupgrade -arR
> cd: can't cd to /usr/ports/devel/libtool13
> ** Package 'libtool' has been removed from ports tree.
> ** Port directory not found: devel/libtool13
> ** Detected a package name change: xmms (multimedia/xmms) ->
> 'xmms-esound' (multimedia/xmms)
> ** No need to upgrade 'xmms-1.2.10_4' (>= xmms-esound-1.2.10_4).
> (specify -f to force)
> ** Listing the failed packages (*:skipped / !:failed)
>         !  (libtool-1.3.5_2)    (port directory error)
> --->  Packages processed: 0 done, 174 ignored, 0 skipped and 1 failed
> az#
> -----------------------------------------------------------------

That port no longer exists. You can delete it and that is it.

You also looked at /usr/src/UPDATING instead of /usr/ports/UPDATING. The 
top of the first entry is

  AFFECTS: all ports using libtool as part of the build process
  AUTHOR: ade at


Kent Stewart
Richland, WA "I am Andean project".

More information about the freebsd-questions mailing list