6.0-release remote x application failure to open display

Heliocentric heliocentric at gmail.com
Wed Feb 22 08:25:39 PST 2006

> I recently have performed a clean install of 6.0-release on this
> machine, on a new hard drive, and then copied over the data and some
> configuration files (ssh keys, etc.) from the old hard drive (it is a
> slow machine, so I didn't want to build current).  Having done so, I
> then tried to login remotely to this machine and run xmms (it is
> mostly used as my "music server"), which failed with this error:
> ** CRITICAL **: Unable to open display
> I have tried with passing the -X flag, and with passing the -Y flag to
> ssh, but there is no change in behaviour.
> Is there something that I have forgotten to enable, or is this unexpected?
first, always use the -X or -Y option for X11 forwarding. regardless
of whether you think it needs to be specified, good habit in case the
environment changes unexpectedly.

next, check the environment after login (setenv in tcsh), make sure
that the DISPLAY variable is being set. should be somwhere along the
lines of localhost:10.0 or higher..

then, whereis xauth and make sure it's installed. ssh uses this to set
up said X display, and isn't installed when X applications are
compiled or installed from binaries (it's in xorg-clients iirc.)

These are fairly general, but are a good start.

More information about the freebsd-questions mailing list