apsfilter question/problem

Denny White dennyboy at cableone.net
Mon Feb 20 10:22:30 PST 2006

Hash: SHA1

On Feb 18 Eric Schuele spake forth boldly:

>> I read the article at Onlamp about printing for the impatient.
>> Installed apsfilter and samba on my old hp netserver so I'd
>> be able to print to an hp 722c deskjet printer connected to
>> an xp box. 
> I don't have a fix to your apsfilter issue, but if you you are interested in 
> another possible printing solution... try:
> http://www.lanside.net/article.php?story=20031007161002250
> It works well for me.  And is simple to setup.
>> Gimp-print was also installed. Ghostscript was
>> already installed. I ran /usr/local/share/apsfilter/./SETUP
>> & thought I had it whipped. That's where the fun started.
>> Apparently I've missed something along the way, since the
>> print job never gets sent to the xp box. I also found out
>> at linuxprinting.org that the recommended hp 722c driver
>> is pnm2ppa. There was only one section in the install script
>> that mentioned that driver, 10) PPA printer, so I chose that.
>> It plugs it into the setup, but when I try to print a test
>> page, I get ERROR: additional filter 'pnm2ppa' not found.
>> I found the driver at linuxprinting.org & downloaded it.
>> How do I go about using it? Is there a way to compile it
>> into ghostscript? I have ghostscript-gnu-nox11-7.07_14 &
>> the apsfilter setup script found it & didn't complain.
>> Do I need to install another more complete version? I know
>> if I install ghostscript-afpl, I'll also have to recompile
>> & reinstall apsfilter with the proper make options. When
>> I choose the more generic just plain deskjet printer driver,
>> the script accepts it, and when I try to print a test page,
>> there's no complaining about the driver like when I try the
>> ppa driver. Test page is created, supposedly sent to the
>> xp printer with even a speed, average around 950 kb/s, but
>> I see where it only goes to stdin. I'm definitely not a
>> programmer, but another filter, ghostscript, something, has
>> to relay it to stdout, is that correct?
>> So, I could use some pointers on this. If anyone interested
>> in answering needs more info, I'll be glad to plug it in to
>> a reply. Like smb.conf, apsfilterrc, & so forth. Thanks.
>> Denny White
> -- 
> Regards,
> Eric

Thanks. Got it installed but couldn't get it to work. Ran into
some real problems with what it did regarding my old Star 2410
dot-matrix printer. I shouldn't have fooled with that to begin
with. I had tried to set the old Star up with CUPS, but there
was no mention of a driver for it, or even the brand of printer.
I know some of the Epson drivers may work with it, but in the
meantime, I kept getting something sent to that printer, even
after I'd removed it from printcap & even rebooted. I fooled around
with the files I could find in /var/spool & downward, moved some
into a backup directory until I could get the old printer to
behave, & then started putting the files back. Afterward, cups
could no longer communicate with anything. I tried doing a
deinstall & reinstall, but the problem persisted. So, it's all
gone now, uninstalled. Will try again later with the other
solution I received in another post. Thanks for trying to help.
I think I've been eaten up by the dumbass in this issue. :)
I know others have trouble too, sometimes, setting up printing,
but I almost screwed my system up, just to print to a damned
winblows puter! :)

GnuPG key  : 0x1644E79A  |  http://wwwkeys.nl.pgp.net
Fingerprint: D0A9 AD44 1F10 E09E 0E67  EC25 CB44 F2E5 1644 E79A

Version: GnuPG v1.4.1 (OpenBSD)


More information about the freebsd-questions mailing list