incorrect superblock error when mounting partition

Glenn Dawson glenn at
Sun Feb 19 02:01:27 PST 2006

At 01:45 AM 2/19/2006, Dave wrote:
>    I've got a 10 gb ide drive that has critical data on one of it's 
> partitions /dev/ad1e. This drive was originally gmirrored in 
> another box it worked fine, it was the master drive. Now i've 
> installed this drive as a slave in another 6.0 box, and now it 
> shows up as ad1 with the partition i want being ad1e. I did a mount 
> -o ro /dev/ad1e /mnt and i'm getting an error "Incorrect 
> superblock" from mount. I then tried fsck /dev/ad1e and got the 
> same error msg. These partitions were formatted with ufs2 as their 
> filesystem. I then ran bsdlabel ad1 and got a printout of my label, 
> this showed up which gives me hope that this data can be retrieved. 
> An error i'm getting says that the c: partition does not cover the 
> entire disk and that may result in utilities not working. Any help appreciated.
>    Some urgency!

Are you sure you don't want ad1s1e?

Also, posting the output from the following commands would go a long 
way in helping you figure out what to do:

fdisk /dev/ad1
bsdlabel /dev/ad1
bsdlabel /dev/ad1s1

And possibly:
bsdlabel /dev/ad1s2
bsdlabel /dev/ad1s3
bsdlabel /dev/ad1s4
depending on what fdisk shows.


>freebsd-questions at mailing list
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list