J.D. Bronson jbronson at wixb.com
Mon Feb 13 05:51:52 PST 2006

I am trying to compile qpopper (from src) and use APOP with the gdbm database.

gdbm was installed from ports and works fine.

I setup my env as such:

LDFLAGS=-L/usr/lib -L/usr/local/lib -R/usr/lib -R/usr/local/lib

and ldconfig shows gdbm:
# ldconfig -r | grep gdbm
         86:-lgdbm.3 => /usr/local/lib/libgdbm.so.3

I ran ./configure --enable-apop
checking ndbm.h usability... yes
checking ndbm.h presence... yes
checking for ndbm.h... yes
checking gdbm.h usability... yes
checking gdbm.h presence... yes
checking for gdbm.h... yes
checking dbm.h usability... no
checking dbm.h presence... no
checking for dbm.h... no
checking for pam_authenticate in -lpam... yes
checking which database manager to use ... checking gdbm ... checking 
for gdbm_open in -lgdbm... yes
found gdbm

so configure detected this....

but then when I ran 'make',
the build fails!

/usr/bin/gcc -c -I.. -I.. -I.  -I../mmangle -I../common   -O2 -pipe 
-mtune=pentium4 -idirafter /usr/local/include -freg-struct-return 
-DHAVE_CONFIG_H  -DFREEBSD -DUNIX popauth.c -o popauth.o
/usr/bin/gcc  -o popauth base64.o scram.o md5.o  hmac.o 
popauth.o  -lgdbm  ../common/libcommon.a
/usr/bin/ld: cannot find -lgdbm
*** Error code 1

Stop in /tmp/qpopper4.1a2/popper.
*** Error code 1

Can anyone point something out to me as to how to get ld to find 
-lgdbm when ldconfig and configure already picked it up?


More information about the freebsd-questions mailing list