Why does portsdb -Uu run so long?

Gerard Seibert gerard at seibercom.net
Sun Feb 5 09:33:43 PST 2006

Xn Nooby wrote:

> > I want to ask you: how long does it take you to cvsup your ports, run
> > 'portsdb
> > -Uu', and finish with 'portversion -l "<" '? To run 'portsnap fetch
> > update',
> > then 'portversion -v | grep needs', it took less then 55 seconds and I was
> > off upgrading ports. The procedure I used had no errors.
> I think it takes about 40 minutes to run portsdb -Uu on my normal P4
> desktop, and several hours inside a virtual machine.  My old P3 laptop took
> 2 hours.  Portsnap took about 1 minute, it was very fast.
> "The procedure I used had no errors."
> Everyone that knows what they are doing never seem to have a problem.
> Generally people say, "I just did a 'portsnap -AbCdDeF' and it worked
> great!", but then it turns out that command was one of many that preceeded
> and followed it, which they neglected to mention.
> Both ways of upgrading work. Neither way will tell you about the conflict
> > between pilot-link and libmal. You're going to have to find out about
> > during
> > an upgrade or, or wait and read about it on the list. So you can't be
> > talking
> > about that as a problem with portsnap. Just what was the problem you had
> > with
> > portsnap?
> I believe I had a "stale dependency with imagemagic" that I chose to "force"
> to continue.  That was on a brand new install, and it happend twice (I tried
> reinstalling).  Maybe I can try to recreate it in a VMWare virtual machine
> so I can reproduce it.
> I think I also got the ruby error, if that was the one that happend about 1
> year ago.  I remember doing an upgrade which broke the system, so I
> reinstalled it a few days later.
>  Also, is it not possible to make a system that does not have conflicts?
> Maybe OS's are simply too complex.  It would seem like there should be a way
> to kick off a global update and rebuild that started with the core pieces
> first, and then moved up the dependency tree level-by-level.  Something that
> was 100% guaranteed to work, and took 1 command.

You could try portmanager 'sysutils/portmanager'. The command:

portmanager -u -f -l -y

will rebuild all of the installed ports in a logical manner as well as
creating a log file for the user to examine if necessary. I would
recommend cleaning out /usr/ports/distfiles and then running:

portsclean -C -D -DD -L -P -PP

prior to running that command. This will ensure that all the crud from
previous installations will be removed ensuring a clean start.

Just my 2¢.

Gerard Seibert
gerard at seibercom.net

     Man invented language to satisfy his deep need to complain.

          Lily Tomlin

More information about the freebsd-questions mailing list