Unable to compile mysql50-server

Roger Merritt mcrogerm at stjohn.ac.th
Wed Feb 1 17:20:41 PST 2006

Yesterday I ran portinstall to install the mysql-server, left the job going 
overnight, and as expected had to reboot this morning. I noticed that 
portinstall did some configuring (which I had forgotten to do when I ran 
"make" the previous times), and I didn't want to waste anything that had 
gotten compiled, so rather than run portinstall again I went back to the 
mysql50-server directory and ran "make", since the configuration files were 
already there. This time I got:
>root at poppy:/usr/ports/databases/mysql50-server# make
>===>  Building for mysql-server-5.0.18
>make  all-recursive
>Making all in include
>make  all-am
>Making all in Docs
>Making all in strings
>Making all in mysys
>Making all in dbug
>Making all in extra
>make  all-recursive
>Making all in regex
>Making all in bdb
>cd build_unix && make all
>Making all in innobase
>make  all-recursive
>Making all in os
>Making all in ut
>Making all in btr
>Making all in buf
>Making all in data
>Making all in dict
>Making all in dyn
>Making all in eval
>Making all in fil
>Making all in fsp
>Making all in fut
>Making all in ha
>Making all in ibuf
>Making all in include
>Making all in lock
>Making all in log
>Making all in mach
>Making all in mem
>Making all in mtr
>Making all in page
>Making all in pars
>Making all in que
>Making all in read
>Making all in rem
>Making all in row
>Making all in srv
>Making all in sync
>Making all in thr
>Making all in trx
>Making all in usr
>Making all in myisam
>Making all in myisammrg
>Making all in heap
>Making all in vio
>Making all in sql
>make  all-recursive
>Making all in share
>if c++ 
>-DDATADIR="\"/var/db/mysql\""  -DSHAREDIR="\"/usr/local/share/mysql\"" 
>-DHAVE_CONFIG_H -I. -I. -I.. -I../bdb/build_unix 
>-I../innobase/include   -I../include -I../include  -I../regex 
>-I.        -DDBUG_OFF -O -pipe -fconserve-space -O 
>-pipe   -felide-constructors -fno-rtti 
>-fno-exceptions   -fno-implicit-templates -fno-exceptions -fno-rtti 
>-DMYSQLD_NET_RETRY_COUNT=1000000 -MT sql_derived.o -MD -MP -MF 
>".deps/sql_derived.Tpo" -c -o sql_derived.o sql_derived.cc;  then mv -f 
>".deps/sql_derived.Tpo" ".deps/sql_derived.Po"; else rm -f 
>".deps/sql_derived.Tpo"; exit 1; fi

After a couple of minutes my console started filling up with messages:
swap-pager: indefinite wait buffer: bufobj: 0, blkno: xxxxxx, size: 4096, 
or sometimes 8192. The blkno varies from 27852 to38249.


More information about the freebsd-questions mailing list