Proper FreeBSD installation practices

Alvaro J. Gurdián AJGurdian at
Wed Feb 1 10:12:52 PST 2006

I looked at the sysinstall and pkg_add man files and noticed that at  
least in pkg_add it was looking for updates at 
Latest/.  I made my way over to that address and noticed indeed  
bind9-9.3.1 was the newest available, then after some browsing I found  
where the was a bind9-9.3.2.

So assumed that both pkg_add and sysinstall were looking up the same  

I tried to tell sysinstall to search a different location:
stable/dns/ mediaSetFTP configPackages

But it just ignored my input and used the same ftp address as it had  

However with pkg_add I had a little further, after setting the  
environment variable PACKAGEROOT to I  
was able to type, pkg_add -r bind9-9.3.2,  and successfully install.   
Or at least so I thought.

To make sure, I went to /var/db/pkg and saw bind9-9.3.2 listed.

Unfortunately when I tried named -v, it replied: version  
9.3.1........what?  How?

By now now I am terrible confused.

What is the difference between 

I thought release was the newest version of stable, and therefore these  
two directories should point to the same info.  Or at least, will they  
merge some time in the future?

Also, I believe I actually installed bind9-9.3.2, if so where is it?   
If not, how can I?

There must be some logical aspect of FreeBSD that I do not understand,  
because installing a package or a port has never been so hard.

Having to set environment variables every time I want to get the newest  
version of a program should not be the standard way to operate, I am  
sure it isn't.


On Jan 31, 2006, at 6:22 PM, Kevin Kinsey wrote:

> Alvaro J. Gurdián wrote:
>> I used sysinstall to look for it: the chose  
>> configure->packages->ftp->main site->package selection->DNS
>> in there I saw several versions of BIND but 9.3.1 was the newest.
>> What am I doing wrong?  I chose FTP to try to get the most up to date  
>> info....what happened?
>> I see 9.3.2 on Fresh ports, why not thru sysinstall?
> sysinstall looks for pre-compiled packages; I don't know if packages
> have been built that include this version of BIND; someone else  
> probably
> does, or can take time to investigate.
> However, even more telling on this issue:  sysinstall uses a
> $RELEASENAME variable (correct name??) to look specifically
> for packages that match the version of FreeBSD that you have installed.
> This means that if you have installed 6.0-RELEASE, your version of
> sysinstall is looking for the packages that were created at the time
> that 6.0-RELEASE was compiled, back in the fall.  Most likely, at that
> time, the lastest BIND was 9.3.1.  You can use some obscure part
> of sysinstall to set this variable to "ANY" and perhaps get a newer
> list of packages.
> It may also be possible to get a later package simply with:
>    $pkg_add -r bind9
> If you have the ports tree installed AND up to date, then:
>   $cd /usr/ports/dns/bind9
>   $make install clean
> will absolutely get you the latest version of the port.
> For more help on installing ports/packages, see handbook chapter 4.
> For more help on "the latest and greatest", see "The Cutting Edge",
> handbook chapter 20.
> Best of luck with FreeBSD!
> Kevin Kinsey
> <<top-posting comment snipped>>  ;-)
> -- 
> In 1869 the waffle iron was invented for people who had wrinkled
> waffles.

More information about the freebsd-questions mailing list