Micah micahjon at ywave.com
Wed Aug 2 03:59:09 UTC 2006

Chad Leigh -- Shire.Net LLC wrote:
> On Aug 1, 2006, at 9:23 PM, Micah wrote:
>> Nope I didn't su, I just ssh'd in as a regular user and immediately 
>> tried xclock. I also tried ssh'ing in as root to see if it's a perms 
>> problem, but root gets the same error. Maybe I've got a configuration 
>> error somewhere? ezjail mounts much of the file system ro, maybe 
>> that's causing a problem?
> Again, I am not an expert, but make sure you have an .Xauthority file in 
> the login dir root of the account you are logging in to and that it has 
> a creation or modification date at the same time you logged in (to make 
> sure that you really are getting it set).
> Chad

Thanks for the idea, here's a test run:

test% ll .Xauthority
-rw-------  1 bsdmjl  bsdmjl   112B Aug  1 20:51 .Xauthority
test% rm .Xauthority
test% exit
Connection to closed.
trisha% ssh -X
Last login: Tue Aug  1 20:51:33 2006 from
Copyright (c) 1980, 1983, 1986, 1988, 1990, 1991, 1993, 1994
         The Regents of the University of California.  All rights reserved.

FreeBSD 6.1-RELEASE-p3 (TRISHA) #1: Sat Jul 15 15:48:17 PDT 2006

Welcome to FreeBSD!

/usr/X11R6/bin/xauth:  creating new authority file /home/bsdmjl/.Xauthority
test% ll .Xauthority
-rw-------  1 bsdmjl  bsdmjl   112B Aug  1 20:51 .Xauthority
test% xclock
X11 connection rejected because of wrong authentication.
X connection to test:10.0 broken (explicit kill or server shutdown).

I'll keep looking....


More information about the freebsd-questions mailing list