BIND inside a jail on FreeBSD 6.0

Chad Leigh -- Shire.Net LLC chad at
Sat Apr 29 01:36:24 UTC 2006

On Apr 28, 2006, at 6:57 PM, patrick wrote:

> I'm trying to run BIND inside a jail on FreeBSD 6.0, and I'm
> encountering the following problem:
> [root at jail /var/named]# /etc/rc.d/named start
> mount_devfs: Operation not permitted
> /etc/rc.d/named: WARNING: devfs_domount(): Unable to mount devfs on
> /var/named/dev
> devfs rule: ioctl DEVFSIO_RAPPLY: Operation not permitted
> devfs rule: ioctl DEVFSIO_RAPPLY: Operation not permitted
> Starting named.
> And then it doesn't start...
> (I realize that BIND already runs in a chroot'd environment, but I'm
> running a second copy of BIND on an existing development server as a
> secondary test environment.)
> The problem looks like it originates in /etc/rc.d/named:
>        # Mount a devfs in the chroot directory if needed
>        #
>        umount ${named_chrootdir}/dev 2>/dev/null
>        devfs_domount ${named_chrootdir}/dev devfsrules_hide_all
>        devfs -m ${named_chrootdir}/dev rule apply path null unhide
>        devfs -m ${named_chrootdir}/dev rule apply path random unhide
> I tried mounting the devfs outside the jail to the jail's
> /var/named/dev, and then commenting out these lines above, but named
> will still not start. Does anyone have any suggestions?

mount a devfs into the jails /dev and you should be all set.  I am  
running bind in a jail under fbsd 6 no problem and I did not have to  
do anything special except set up the jail according to man jail


> Thanks,
> Patrick
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions- 
> unsubscribe at"

Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at

More information about the freebsd-questions mailing list