Wanted: Flash player for <browser_of_choice>....

ballona rcbballona at gmail.com
Fri Apr 28 13:25:23 UTC 2006


I've found this topic another day and today I've subscribed to this list 
in order to post this message that I hope could be helpful to someone.

I've recentely managed to make linux-firefox ports to install 
flashplayer automatically (i.e. without relying on www/flashplugin 
ports) on freebsd (which I've never managed to do before).  Even better, 
it's installed version 7 or flashplayer which I've almost never managed 
to run with firefox ports.

I'm not a lawyer too but as flashplayer was not installed via ports and 
as it was firefox itself that fetch, downloaded and installed it, I 
think it's  technically running under firefox regardless wherever 
firefox is running on.  But that's only my guess...

I'll described what happened so that anyone that want, can try and make 
it work to.  I don't know exactely what make it work as I've tried it 
before without success.  That's why I will explain the steps I took but 
I don't know which ones are relevant to the result I've achieved.

1) I run fredbsd current 7.

2) I always have firefox and flashplugin ports installed on my system 
and by adjusting /etc/libmap.conf I had success on displaying pages with 
flash contents, although I've always have problems when I installed 
newer versions of firefox or flashplugin.  After such updates it was 
common that firefox crash when it find flash content and sometimes I 
wasn't able to fix it.  The last time it happened I've only managed to 
avoid it to crash when it find flash content, but it didn't show any 
flash content in the page but only a frame where flash contend should be.

3)  Tired of fixing these problems I tried to install linux-firefox that 
I've heard that would have better results.  It really has, because after 
install, it played flash contents without any other adjustments.  I 
think linux-firefox continue to rely on www/flashplayer ports to play 
flash contents but it seems to do it better.  I noticed that it used 
flashplayer version 6, the same that I used to use with firefox ports.  
Now I had firefox and linux-firefox installed at the same time in my 
system and the nice thing was that bookmarks, extensions and etc were 
shared by both.

4) Recentelly during a ports update, portupgrade advise that flashplugin 
would be deinstallled as a license problem was identified. I've accepted 
it and it was automatically deinstalled.

5) After that when I use firefox, it started to crash again when it 
finds any flash content in a page and I realized it was because 
flashplugin have been deinstalled (at that time I wasn't aware of the 
HOLD_PKGS =['linuxpluginwrapper*' option to prevent it of being 
deinstalled and after deinstalled it didn't help to have it and try to 
install flashplugin again).

6) Then I tried to run linux-firefox.  It hasn't crashed when it finds 
flash contents but couldn't play it too.  But instead of crashing it 
showed an upper bar saying that a plugin is missing and ask if it can 
try to fetch and install it for me.  I've said yes but unfortunately 
it's said it couldn't find an appropriate plugin and that I had to do it 

7) After that I've gave up and try to find anyone with the same problem 
in any forum.  Then I've found this thread "Re: Wanted: Flash player for 
<browser_of_choice>...." with interesting information about the subject 
but aparentely without any real solution, apart from asking adobe for a 
native version or a change in license.

8) Then I found someone saying that have tried gnash (GNU Flash movie 
player) without success either but that it could be a viable alternative.

9) So I tried to install gnash with the following command: sudo 
portupgrade -R -r -N -i gnash

10) Then I realized that it was better to gave it the "WITH_FIREFOX=yes" 
option and  so I did: sudo vi /usr/ports/graphics/gnash/Makefile and 
included that option there (I don't know it there is a better way to ddo 
that) running the installation again with the command: sudo portupgrade 
-R -r -N -i -f gnash.  This time it asked me where was the firefox 
binary and I pointed it to the linux-firefox binary that had installed 
in my system.

11) After that I tried to run linux-firefox again in a page with flash 
contents.  And again it doesn't show any flash content but only the 
upper bar saying a plugin is missing.

12) I then tried to find any evidence that linux-firefox was aware of 
gnash in any way by inspecting about, tools menu, extensions etc, but 
without success.

13) Finally I clicked in the upper bar so that linux-firefox could try 
again to fetch and install flashplugin by itself.  I was surprised when 
the progress bar start to move saying it has been found and was being 
installed.  It finished successfully and after that linux-firefox 
started to show flash contents correctely and and when I right click in 
any flash contents I realized that it was flashplayer 7 that was running.

I don't know what has changed to make it be able to install flashplugin 
automatically but maybe it can help someone with thee same problem.



More information about the freebsd-questions mailing list