Problem Restoring Dump Via Fixit Environment in FreeBSD 6.0 Release Boot Cdrom

backyard1454-nospam at backyard1454-nospam at
Tue Apr 18 14:38:44 UTC 2006

--- John Nielsen <lists at> wrote:

> On Tuesday 18 April 2006 00:17, Brian McKeon wrote:
> > Hello I'm having a problem restoring my backup of
> my FreeBSD

> >
> > mount /dev/da0s1 /foobar fails with superblock
> errors (obviously)
> > mount -t ext2fs /dev/da0s1 /foobar fails with
> mount_ext2fs not found in
> > /usr/sbin (perhaps /sbin)
> >
> > when I got to /mnt2/usr/sbin (think thats the
> right path, i know ls
> > ./mount_ext2fs finds the file in the path but if
> its ./usr/sbin or
> > ./sbin I can't recall) and run ./mount_ext2fs
> /dev/da0s1 /foobar I get
> > operation not supported by device.
> >
> > fixit won't even let me mount my linux boot drive
> (same sets of errors)
> > so I know it isn't just failing because of the USB
> device.
> >
> >
> > }--> My question is what is going wrong here? Do I
> have to make a
> > symlink to mount_ext2fs to the path that mount -t
> xxx blah wants to see
> > that program? Or am I just cursed? I figured
> restoring a backup would be
> > pretty simple but Fixit doesn't seem to want to
> cooperate.To date this
> > is my only serious issue with FreeBSD, but I would
> say it is quite the
> > issue to have. 
> One thing you need to make sure of when using the
> Fixit CD is that the kernel 
> can find the necessary modules for whatever you're
> trying to do.  In the case 
> of ntfs.ko and smbfs.ko (and I presume ext2fs.ko),
> this doesn't happen by 
> default.  To fix this, change the kernel's module
> path from the minimal one 
> in the MFS root to the complete one included on the
> CD:
> sysctl kern.module_path="/dist/boot/kernel"
> Then try your mount_ext2fs command again.
> Also, remember to check the "debug" console (Alt-F2)
> to see if there are any 
> kernel messages that might shed additional light on
> the problem.
> Good luck, and please post again even if just to say
> "it worked".
> JN

Yeah that worked pretty good. I new I needed to make
up my own fixit boot image install program (hate
sysinstall, know I'm not the only one...) But as a
quick fix this did the trick. At least it mounted the
drives, now to the restore...



More information about the freebsd-questions mailing list