Problem Restoring Dump Via Fixit Environment in FreeBSD 6.0 Release Boot Cdrom

John Nielsen lists at
Tue Apr 18 13:55:18 UTC 2006

On Tuesday 18 April 2006 00:17, Brian McKeon wrote:
> Hello I'm having a problem restoring my backup of my FreeBSD
> installation. I recently upgraded hardrives in my laptop and made
> backups of my Gentoo and FreeBSD partitions. Gentoo restored with no
> troubles BSD however... I have made a dump of my filesystems and copied
> them onto an Ext2fs USB drive. When I boot with the 6.0 Release CDrom
> and run FIXIT to try and restore the dumps I run into problems. While I
> know the system detects the USB device, and fdisk -s (or is it l I get
> linux/unix command lines screwed up when I'm not at the prompt...)
> detects a linux native partition on the drive that seems to be as far as
> the system will allow me to go.
> mount /dev/da0s1 /foobar fails with superblock errors (obviously)
> mount -t ext2fs /dev/da0s1 /foobar fails with mount_ext2fs not found in
> /usr/sbin (perhaps /sbin)
> when I got to /mnt2/usr/sbin (think thats the right path, i know ls
> ./mount_ext2fs finds the file in the path but if its ./usr/sbin or
> ./sbin I can't recall) and run ./mount_ext2fs /dev/da0s1 /foobar I get
> operation not supported by device.
> fixit won't even let me mount my linux boot drive (same sets of errors)
> so I know it isn't just failing because of the USB device.
> The running system allowed me to mount to drive and write to it or I
> wouldn't have the dumps on it, but I can't figure out why Fixit won't
> let me use the drive for more then a paperweight. All the googling I've
> done says just boot and mount the ext2 partition...
> }--> My question is what is going wrong here? Do I have to make a
> symlink to mount_ext2fs to the path that mount -t xxx blah wants to see
> that program? Or am I just cursed? I figured restoring a backup would be
> pretty simple but Fixit doesn't seem to want to cooperate.To date this
> is my only serious issue with FreeBSD, but I would say it is quite the
> issue to have. All my previous restores occurred with a running FreeBSD
> system and the "new" drive somewhere else in the chain, but my Laptop
> supports only the one drive (well without rigging up somekind of
> adapters to add a slave port connection... not on my to do list) I could
> get the adapters and make the restore with my desktop but the whole
> point for me was being able to easily restore my laptop from
> catastrophic failure on the road, short of running the thing over that is.

One thing you need to make sure of when using the Fixit CD is that the kernel 
can find the necessary modules for whatever you're trying to do.  In the case 
of ntfs.ko and smbfs.ko (and I presume ext2fs.ko), this doesn't happen by 
default.  To fix this, change the kernel's module path from the minimal one 
in the MFS root to the complete one included on the CD:

sysctl kern.module_path="/dist/boot/kernel"

Then try your mount_ext2fs command again.

Also, remember to check the "debug" console (Alt-F2) to see if there are any 
kernel messages that might shed additional light on the problem.

Good luck, and please post again even if just to say "it worked".


More information about the freebsd-questions mailing list