Hosed my MBR?

Jerry McAllister jerrymc at clunix.cl.msu.edu
Fri Apr 14 16:49:52 UTC 2006

> On Fri, Apr 14, 2006 at 11:51:58AM -0400, Jerry McAllister wrote:
> > > > 
> > > > In your case, it sounds like you have two raid devices, one on
> > > > each controller.   You would have to have an MBR on each and it
> > > > sounds like you think you wiped the one on the INTEL controller.
> > > > Figure out what device name the raid on the INTEL controller comes
> > > > up as and then write the MBR to that.
> > > > 
> > > Thanks for your response.  My follow-up question to you is how would
> > > running a FBSD fdisk command on the Intel controller fix a hosed
> > > WinXP MBR?  Or is an MBR OS agnostic?
> > 
> > Well, the FreeBSD MBR is.   I have used a FreeBSD MBR to fix a hosed
> > MBR (hosed by Ghost) on an XP only (eg. no FreeBSD on it) machine and
> > it worked fine.  
> > 
> really?  I suspect it was sysinstall's fdisk that hosed my MBR on the
> Intel controller in the first place.  Cause now it brings up a broken
> FreeBSD boot loader instead of the WinXP loader.
> > I suspect it might not work in the reverse direction, though.  The MS
> > MBR is not known for playing nice with other OS boot sectors.  I don't
> > know what the difference it.
> > 
> hmmm...
> > Is there some other disk and [preferrably SCSI] controller you can
> > stick in and install FreeBSD on and try to mount and check out the
> > raid that you think is hosed before doing anything irreversable?  I
> > forgot if you said you had tried looking at it with a fixit disk but
> > that might work if the raid is hardware raid.
> > 
> I can still boot FreeBSD off my FastTrack controller (ar0), that's where
> I'm writing this email from.  I can see both the Intel RAID device
> (ar1), and mount the data from NTFS (ar1s1), and newly created UFS-2
> (ar1s2).  I even did a dd of the MBR from ar0 and ar1 and compared the
> two.  Of course, I don't know what I'm looking at so that didn't go too
> far :)

This has lasted long enough that I am forgetting parts, such as it
is the MS piece that doesn't boot, not the FreeBSD.

But, if you get a FreeBSD boot loader, then it is not the MBR that is
hosed, but the boot sector itself.  Probably bsdlabel wrote on it and
not fdisk.  That could be a little more difficult, since those boot
sectors can be quite different and are not OS agnostic.

In this case, your best bet may be to mount the MS file system from 
the FreeBSD side and copy it somewhere for safety and then try to 
rebuild the MS system "from scratch".   Note, I said 'may' be.  If
someone was to raise an argument, I would fall over easily.
But, you should still be able to mount the MS file slice and
read it from the FreeBSD side and use that to check it and squirrel
it away somewhere.  Here is an fstab entry I use on this machine to
mount my MS-XP slice as /mydos:
/dev/ad0s2              /mydos          msdos   rw              0       0
It happens to be FAT, but there is one for NTFS as well.  But, last I
checked, FreeBSD can read, but not write NTFS, just FATs.


> -- 
> Regards,
> Doug
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list