Hosed my MBR?

Doug Poland doug at polands.org
Fri Apr 14 16:13:35 UTC 2006

On Fri, Apr 14, 2006 at 11:51:58AM -0400, Jerry McAllister wrote:
> > > 
> > > In your case, it sounds like you have two raid devices, one on
> > > each controller.   You would have to have an MBR on each and it
> > > sounds like you think you wiped the one on the INTEL controller.
> > > Figure out what device name the raid on the INTEL controller comes
> > > up as and then write the MBR to that.
> > > 
> > Thanks for your response.  My follow-up question to you is how would
> > running a FBSD fdisk command on the Intel controller fix a hosed
> > WinXP MBR?  Or is an MBR OS agnostic?
> Well, the FreeBSD MBR is.   I have used a FreeBSD MBR to fix a hosed
> MBR (hosed by Ghost) on an XP only (eg. no FreeBSD on it) machine and
> it worked fine.  
really?  I suspect it was sysinstall's fdisk that hosed my MBR on the
Intel controller in the first place.  Cause now it brings up a broken
FreeBSD boot loader instead of the WinXP loader.

> I suspect it might not work in the reverse direction, though.  The MS
> MBR is not known for playing nice with other OS boot sectors.  I don't
> know what the difference it.

> Is there some other disk and [preferrably SCSI] controller you can
> stick in and install FreeBSD on and try to mount and check out the
> raid that you think is hosed before doing anything irreversable?  I
> forgot if you said you had tried looking at it with a fixit disk but
> that might work if the raid is hardware raid.
I can still boot FreeBSD off my FastTrack controller (ar0), that's where
I'm writing this email from.  I can see both the Intel RAID device
(ar1), and mount the data from NTFS (ar1s1), and newly created UFS-2
(ar1s2).  I even did a dd of the MBR from ar0 and ar1 and compared the
two.  Of course, I don't know what I'm looking at so that didn't go too
far :)


More information about the freebsd-questions mailing list