Hosed my MBR?

Jerry McAllister jerrymc at clunix.cl.msu.edu
Tue Apr 11 17:27:13 UTC 2006

> On Tue, April 11, 2006 09:08, Jerry McAllister wrote:
> >>
> >> I'm in a bit of a mess here.  I've got an Asus P4C800-E Deluxe
> >> motherboard with two on-board SATA RAID controllers, an Intel
> >> MatrixRAID (ICH5R) and Promise Fasttrak (PDC20378).  My BIOS allows
> >> me to boot from either the Promise or the Intel controller.
> >>
> >
> > Well, the install CD is also the fixit CD.  You can try booting from
> > it and choosing the shell and then trying to run the fdisk from that
> > environment to replace the MBR.
> >
> > I have done that for people who have hosed their MBR on machines with
> > Ghost - even their XP only, no FreeBSD, systems, using the FreeBSD
> > fixit, I ran fdisk and replaced the MBR with the FreeBSD MBR and it
> > worked just fine.
> >
> Hi Jerry,
> I think the root of my confusion here is the fact that I have two RAID
> controllers and can boot off either controller.
> Does that mean I have two MBR's, one for each controller?  If that's
> the case and I boot off a CD-ROM, which MBR am I fixing?

Are both controllers part of the same raid device?   say you have some
disk on one and others on the other and they are all lumped in to the
same raid device?    I don't even know if you can do that as I haven't
tried or looked at it.   But, it goes by the address you use in 
the fdisk command.    

I don't know if it being raid messes things up or not.   Any time I have 
done anything with raid, I had a separate boot and system device outside 
of the raid.  The raid was lumping together disks to make a larger 
work data storage.

Anyway, there needs to be an MBR on each bootable device as well as the
boot files.   I think that holds true for raid setups as well.  

In addition, the first bootable device that your BIOS sees must have 
an MBR regardless of whether you have 1 or more bootable devices.

In your case, it sounds like you have two raid devices, one on each
controller.   You would have to have an MBR on each and it sounds like 
you think you wiped the one on the INTEL controller.   Figure out what
device name the raid on the INTEL controller comes up as and then write
the MBR to that.

> -- 
> Regards,
> Doug
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list