Hosed my MBR?

Doug Poland doug at polands.org
Tue Apr 11 15:25:11 UTC 2006

On Tue, April 11, 2006 09:08, Jerry McAllister wrote:
>> I'm in a bit of a mess here.  I've got an Asus P4C800-E Deluxe
>> motherboard with two on-board SATA RAID controllers, an Intel
>> MatrixRAID (ICH5R) and Promise Fasttrak (PDC20378).  My BIOS allows
>> me to boot from either the Promise or the Intel controller.
> Well, the install CD is also the fixit CD.  You can try booting from
> it and choosing the shell and then trying to run the fdisk from that
> environment to replace the MBR.
> I have done that for people who have hosed their MBR on machines with
> Ghost - even their XP only, no FreeBSD, systems, using the FreeBSD
> fixit, I ran fdisk and replaced the MBR with the FreeBSD MBR and it
> worked just fine.
Hi Jerry,

I think the root of my confusion here is the fact that I have two RAID
controllers and can boot off either controller.

Does that mean I have two MBR's, one for each controller?  If that's
the case and I boot off a CD-ROM, which MBR am I fixing?


More information about the freebsd-questions mailing list