cdrecord on Thinkpad T43

Erin Sharmahd tuxgirl at
Sat Apr 8 19:22:33 UTC 2006

I've been having some problems getting cdrecord to work on my thinkpad. says:
"To burn CDs with cdrecord don't forget to enable atapicam during
kernel configuration."

In his kernel config, he used this with "device atapicd", so I ran:
[amon-re /root] cat /sys/i386/conf/GENERIC | grep atapicd
device          atapicd         # ATAPI CDROM drives

In the past (on Linux), I had always used 'cdrecord dev=/dev/cdrom',
so I initially tried 'cdrecord dev=/dev/acd0', but I learned from
'cdrecord dev=help' that apparently "open via UNIX device" is not
supported.  "SCSI Bus scanning" is supposed to be supported, but when
I run 'cdrecord -scanbus', it gives:
[amon-re /root] cdrecord -scanbus
Cdrecord-Clone 2.01 (i386-unknown-freebsd6.1) Copyright (C) 1995-2004
Jörg Schilling
cdrecord: Error 0. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

(it would be nice if cdrecord -scanbus didn't tell me to run it
again... but that's a different issue)

Here is some (hopefully) relevant information about my system:

[amon-re /root] uname -a
FreeBSD amon-re 6.1-PRERELEASE FreeBSD 6.1-PRERELEASE #1: Sat Feb 11
21:55:30 MST 2006     zoot at amon-re:/usr/obj/usr/src/sys/GENERIC  i386

[amon-re /root] sysctl -a | grep -i cd 5 15
  allocdirect     4     1K       -    79793  128
   acd_driver     1     2K       -        1  2048
         cdev    31     4K       -       31  128
debug.sizeof.cdev: 184
debug.sizeof.cdev_priv: 216
dev.acpi_ec.0.%desc: Embedded Controller: GPE 0x1c, ECDT
dev.cbb.0.%location: slot=0 function=0 handle=\_SB_.PCI0.PCI1.CDBS
dev.acd.0.%desc: MATSHITADVD-RAM UJ-822S/1.61
dev.acd.0.%driver: acd
dev.acd.0.%parent: ata1

[amon-re /root] dmesg | grep -i cd
acpi_ec0: <Embedded Controller: GPE 0x1c, ECDT> port 0x62,0x66 on acpi0
acd0: DVDR <MATSHITADVD-RAM UJ-822S/1.61> at ata1-master UDMA33

I'd appreciate any help that anyone can provide.  I'm somewhat
stumped, and I'm not seeing much on google regarding this problem.



More information about the freebsd-questions mailing list