src upgrade from 4.11-p16 to 5.4 possible?

Derek Ragona derek at
Fri Apr 7 15:05:14 UTC 2006

I recently did this exact operation.  It went fine for me on my second 
try.  The first one I determined didn't go well as I didn't have the system 
up to date first.  So on my second attempt I made sure my 4.11 system was 
up to date, and did a complete buildworld, buildkernel, etc.  Once I was 
sure it was completely up to date on 4.11, I:
Saved my kernel config file to:
rm -rf /usr/src
rm -rf /usr/ports

I changed my cvsup tag and pulled new source.  Then I meticulously followed 
the instructions in /etc/src/UPDATING.  Read those instructions, be sure to 
update your /etc/make.conf file for the right CPU.

I did need to create a new kernel configuration file starting with GENERIC 
and boot.hints from my old 4.11 kernel configuration file.

All went well except one library didn't get put in place when I did the 
installworld.  It was built but just not in place, so I saw an error when I 
booted the system, and moved it manually.

The library that didn't get moved was:

I did add:
COMPAT4X=       yes
to my make.conf file and
options         COMPAT_FREEBSD4         # Compatible with FreeBSD4
to my kernel config file, but still had to make sasl2 and sendmail for 
sasl2.  Otherwise the ports I had seemed to mostly work.  But you might 
want to do a:
portupgrade -a


At 08:27 AM 4/7/2006, B. Cook wrote:
>Hello all,
>I am running a set of 5 FreeBSD 4.11 p16 servers here at the library.
>For various reasons we are unable to 'get new drives' and install FreeBSD 
>5/6 and then migrate userland data to a new drive.
>I have been able to get my hands on a test box from someone to test src 
>upgrading from 4.11 to something more current like 5.x and then updating 
>from there.
>My standard running machines are Dual 933 Intel machines, 1G ram, scsi 
>drives.. etc
>This test box is an AMD Mobile Sempron 2600+ w/ 512M ram, 80G ide drives.
> is the guide 
>that I am following.. and I have done what I think are the right steps.. 
>and I am getting a crash/failure in a most unusual place.
>Stop in /usr/src/usr.sbin/pcvt/vgaio.
>*** Error code 1
>===> usr.sbin/pcvt/ispcvt
>cc -O -pipe   -c /usr/src/usr.sbin/pcvt/ispcvt/ispcvt.c
>cc -O -pipe    -o ispcvt ispcvt.o
>gzip -cn /usr/src/usr.sbin/pcvt/ispcvt/ispcvt.8 > ispcvt.8.gz
>===> usr.sbin/pcvt/vgaio
>cc -O -pipe  -I/usr/obj/usr/src/usr.sbin/pcvt/vgaio 
>-I/usr/src/usr.sbin/pcvt/vgaio  -c vgaio.c
>In file included from /usr/src/usr.sbin/pcvt/vgaio/vgaio.y:56:
>/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h:60: error: syntax 
>error before "bsfl"
>/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h:60: error: syntax 
>error before "mask"
>/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h: In function `bsfl':
>... etc
>The strange thing is this:
>CPU: Mobile AMD Sempron(tm) Processor 2600+ (799.92-MHz 686-class CPU)
>this is what dmesg tells me about this cpu.. again this is under 4.11
>So I am wondering if these things are related, and if I try this on an 
>Intel cpu will I still have this issue?
>As my cvsup to RELENG_5_4 and then make buildworld fails at this point.
>I have script'd the make buildworld which is a 9M text file, and it 
>compresses down to a ~500k bz/gz file if anyone is interested in it.
>I have tried in single user mode as well again no difference.  I have 
>tried make -j4 buildworld (only gets there faster.. )
>Thanks in advance any help is greatly appreciated.
>(I'm going to try 5.3 and then if that doesn't work then I'll try 5.2.1)
>- Brian
>freebsd-questions at mailing list
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list