Login broken and rc.conf variables suddenly invalid after kernel/world upgrade (?!?!)

Bill Moran wmoran at collaborativefusion.com
Fri Apr 7 12:11:27 UTC 2006

On Thu, 6 Apr 2006 21:14:33 -0700
Garrett Cooper <youshi10 at u.washington.edu> wrote:

> 	So, I basically upgraded my source again and did installworld. Had  
> to run make quite a few times because it appeared that the makefile  
> for /usr/src was broken (or at least the targets were incorrect since  
> it kept on complaining about stuff not being compiled in buildworld).  
> So I ran mergemaster, and things appeared to be running smoothly, but  
> now it appears that my system is screwed up, due to bash. Granted, I  
> used bash as my login shell for both root and my local account, and  
> to solve this problem I tried recompiling the program from ports in  
> single user mode, but every single time I login it complains about  
> not being able to find libintl.so.6 (I believe), which is a part of  
> gettext. I eventually gave up on trying to reinstall and fix bash and  
> gettext, but when I try and login, the stupid machine still claims to  
> be missing the library, regardless of the fact that it's no longer my  
> login shell and I sed'ed both /etc/shells and /etc/passwd and /etc/ 
> master.passwd so that they no longer have bash in them.
> 	I'm just basically stumped and I need a lot of help here, because  
> the machine's inaccessible (the rc 'daemon' complains all the  
> variables setup in rc.conf aren't valid--although they are), and I  
> would greatly appreciate any help anyone can give me.

It doesn't sound like you correctly followed the upgrade procedure, since
there is no "make" in that procedure.

Additionally, you can't just change /etc/master.passwd without running
cap_mkdb to have the changes take effect.

But, most important, this email isn't detailed enough for us to give you
much help.  Please provide details, such as
*) what version did you upgrade from and to
*) What, exact, commands did you run, in what order
*) What, exact, errors did you get

As a hint for future work: If you think a Makefile provided by the FreeBSD
team is "broken", the wisest course of action would be to post here _before_
you commit to an upgrade that is unlikey to work.

Bill Moran

More information about the freebsd-questions mailing list